summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-mainline/defconfig1
-rw-r--r--recipes-kernel/linux/linux-mainline_3.14.bb37
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-mainline/defconfig b/recipes-kernel/linux/linux-mainline/defconfig
new file mode 100644
index 00000000..926b35a5
--- /dev/null
+++ b/recipes-kernel/linux/linux-mainline/defconfig
@@ -0,0 +1 @@
use-kernel-config=omap2plus_defconfig
diff --git a/recipes-kernel/linux/linux-mainline_3.14.bb b/recipes-kernel/linux/linux-mainline_3.14.bb
new file mode 100644
index 00000000..559a79b2
--- /dev/null
+++ b/recipes-kernel/linux/linux-mainline_3.14.bb
@@ -0,0 +1,37 @@
1SECTION = "kernel"
2DESCRIPTION = "Mainline Linux kernel"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6inherit kernel
7
8require recipes-kernel/linux/linux-dtb.inc
9require recipes-kernel/linux/setup-defconfig.inc
10
11# Pull in the devicetree files into the rootfs
12RDEPENDS_kernel-base += "kernel-devicetree"
13
14# Add a run-time dependency for the PM firmware to be installed
15# on the target file system.
16RDEPENDS_kernel-base_append_ti33x = " am33x-cm3"
17
18# Default is to package all dtb files for ti33x devices unless building
19# for the specific beaglebone machine.
20KERNEL_DEVICETREE_ti33x = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb am335x-boneblack.dtb"
21KERNEL_DEVICETREE_beaglebone = "am335x-bone.dtb am335x-boneblack.dtb"
22
23KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
24
25COMPATIBLE_MACHINE = "ti33x"
26
27S = "${WORKDIR}/git"
28
29BRANCH = "master"
30
31# Corresponds to tag v3.14-rc8
32SRCREV = "b098d6726bbfb94c06d6e1097466187afddae61f"
33PV = "3.13+3.14rc8"
34
35SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;branch=${BRANCH} \
36 file://defconfig \
37 "