summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-keystone-3.13/defconfig1
-rw-r--r--recipes-kernel/linux/linux-keystone-rt/defconfig1
-rw-r--r--recipes-kernel/linux/linux-keystone-rt_3.10.bb33
-rw-r--r--recipes-kernel/linux/linux-keystone/defconfig1
-rw-r--r--recipes-kernel/linux/linux-keystone_3.10.bb33
-rw-r--r--recipes-kernel/linux/linux-keystone_3.13.bb34
-rw-r--r--recipes-kernel/linux/linux-mainline/defconfig1
-rw-r--r--recipes-kernel/linux/linux-mainline_3.14.bb41
-rw-r--r--recipes-kernel/linux/linux-ti-glsdk/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-glsdk_3.8.bb32
-rw-r--r--recipes-kernel/linux/linux-ti-staging-3.14/configs/systest1
-rw-r--r--recipes-kernel/linux/linux-ti-staging-3.14/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-staging_3.14.bb67
-rw-r--r--recipes-kernel/linux/multi-kernel.inc140
-rw-r--r--recipes-kernel/linux/sitara-linux-ti-staging-3.14/defconfig1
-rw-r--r--recipes-kernel/linux/sitara-linux-ti-staging_3.14.bb51
16 files changed, 0 insertions, 439 deletions
diff --git a/recipes-kernel/linux/linux-keystone-3.13/defconfig b/recipes-kernel/linux/linux-keystone-3.13/defconfig
deleted file mode 100644
index bcfc4821..00000000
--- a/recipes-kernel/linux/linux-keystone-3.13/defconfig
+++ /dev/null
@@ -1 +0,0 @@
1use-kernel-config=keystone_defconfig
diff --git a/recipes-kernel/linux/linux-keystone-rt/defconfig b/recipes-kernel/linux/linux-keystone-rt/defconfig
deleted file mode 100644
index 731bb00d..00000000
--- a/recipes-kernel/linux/linux-keystone-rt/defconfig
+++ /dev/null
@@ -1 +0,0 @@
1use-kernel-config=keystone2_fullrt_defconfig
diff --git a/recipes-kernel/linux/linux-keystone-rt_3.10.bb b/recipes-kernel/linux/linux-keystone-rt_3.10.bb
deleted file mode 100644
index b914c52c..00000000
--- a/recipes-kernel/linux/linux-keystone-rt_3.10.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux RT kernel for TI Keystone devices"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6COMPATIBLE_MACHINE = "keystone"
7
8inherit kernel
9
10require recipes-kernel/linux/linux-dtb.inc
11require recipes-kernel/linux/setup-defconfig.inc
12
13MACHINE_KERNEL_PR_append = "e"
14PR = "${MACHINE_KERNEL_PR}"
15
16KERNEL_DEVICETREE_k2hk-evm = "k2hk-evm.dtb"
17KERNEL_DEVICETREE_k2e-evm = "k2e-evm.dtb"
18KERNEL_DEVICETREE_k2l-evm = "k2l-evm.dtb"
19
20KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
21
22#This commit corresponds to "K2_RT_LINUX_03.10.72_15.08"
23SRCREV = "dfe5ac2e9d7dba93fad48ca761933503dbdecae2"
24PV = "3.10.72+git${SRCPV}"
25
26BRANCH = "v3.10.72/master-rt"
27SRC_URI = "git://git.ti.com/keystone-linux/linux.git;protocol=git;branch=${BRANCH}\
28 file://defconfig\
29 "
30
31S = "${WORKDIR}/git"
32
33RDEPENDS_kernel-base = ""
diff --git a/recipes-kernel/linux/linux-keystone/defconfig b/recipes-kernel/linux/linux-keystone/defconfig
deleted file mode 100644
index 04e6b178..00000000
--- a/recipes-kernel/linux/linux-keystone/defconfig
+++ /dev/null
@@ -1 +0,0 @@
1use-kernel-config=keystone2_defconfig
diff --git a/recipes-kernel/linux/linux-keystone_3.10.bb b/recipes-kernel/linux/linux-keystone_3.10.bb
deleted file mode 100644
index 85eecb6b..00000000
--- a/recipes-kernel/linux/linux-keystone_3.10.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for TI Keystone devices"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6COMPATIBLE_MACHINE = "keystone"
7
8inherit kernel
9
10require recipes-kernel/linux/linux-dtb.inc
11require recipes-kernel/linux/setup-defconfig.inc
12
13MACHINE_KERNEL_PR_append = "e"
14PR = "${MACHINE_KERNEL_PR}"
15
16KERNEL_DEVICETREE_k2hk-evm = "k2hk-evm.dtb"
17KERNEL_DEVICETREE_k2e-evm = "k2e-evm.dtb"
18KERNEL_DEVICETREE_k2l-evm = "k2l-evm.dtb"
19
20KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
21
22#This commit corresponds to "K2_LINUX_03.10.72_15.08"
23SRCREV = "ca334dedb5c234b1602d991d9b330360a5bc97ad"
24PV = "3.10.72+git${SRCPV}"
25
26BRANCH = "v3.10.72/master"
27SRC_URI = "git://git.ti.com/keystone-linux/linux.git;protocol=git;branch=${BRANCH}\
28 file://defconfig\
29 "
30
31S = "${WORKDIR}/git"
32
33RDEPENDS_kernel-base = ""
diff --git a/recipes-kernel/linux/linux-keystone_3.13.bb b/recipes-kernel/linux/linux-keystone_3.13.bb
deleted file mode 100644
index dc53e42b..00000000
--- a/recipes-kernel/linux/linux-keystone_3.13.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for TI Keystone devices"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6COMPATIBLE_MACHINE = "keystone"
7
8inherit kernel
9
10require recipes-kernel/linux/linux-dtb.inc
11require recipes-kernel/linux/setup-defconfig.inc
12
13# Look in the generic major.minor directory for files
14FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-3.13:"
15
16MACHINE_KERNEL_PR_append = "a"
17PR = "${MACHINE_KERNEL_PR}"
18
19# Only k2hk DTB is available in this version
20KERNEL_DEVICETREE_k2hk-evm = "k2hk-evm.dtb"
21
22KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
23
24SRCREV = "11a8eaee39b68e6047f07382c251786b40bef165"
25PV = "3.13.0+git${SRCPV}"
26
27BRANCH = "v3.13/master"
28SRC_URI = "git://git.ti.com/keystone-linux/linux.git;protocol=git;branch=${BRANCH}\
29 file://defconfig\
30 "
31
32S = "${WORKDIR}/git"
33
34RDEPENDS_kernel-base = ""
diff --git a/recipes-kernel/linux/linux-mainline/defconfig b/recipes-kernel/linux/linux-mainline/defconfig
deleted file mode 100644
index 926b35a5..00000000
--- a/recipes-kernel/linux/linux-mainline/defconfig
+++ /dev/null
@@ -1 +0,0 @@
1use-kernel-config=omap2plus_defconfig
diff --git a/recipes-kernel/linux/linux-mainline_3.14.bb b/recipes-kernel/linux/linux-mainline_3.14.bb
deleted file mode 100644
index b1d4eecc..00000000
--- a/recipes-kernel/linux/linux-mainline_3.14.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SECTION = "kernel"
2DESCRIPTION = "Mainline Linux kernel"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6inherit kernel
7
8require recipes-kernel/linux/linux-dtb.inc
9require recipes-kernel/linux/setup-defconfig.inc
10
11# Pull in the devicetree files into the rootfs
12RDEPENDS_kernel-base += "kernel-devicetree"
13
14# Add a run-time dependency for the PM firmware to be installed
15# on the target file system.
16RDEPENDS_kernel-base_append_ti33x = " am33x-cm3"
17
18# Default is to package all dtb files for ti33x devices unless building
19# for the specific beaglebone machine.
20KERNEL_DEVICETREE_ti33x = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb am335x-boneblack.dtb"
21KERNEL_DEVICETREE_beaglebone = "am335x-bone.dtb am335x-boneblack.dtb"
22KERNEL_DEVICETREE_omap3 = "omap3-beagle.dtb omap3-beagle-xm.dtb omap3-evm.dtb omap3-evm-37xx.dtb am3517-evm.dtb"
23KERNEL_DEVICETREE_am3517-evm = "am3517-evm.dtb"
24KERNEL_DEVICETREE_am37x-evm = "omap3-evm-37xx.dtb"
25KERNEL_DEVICETREE_beagleboard = "omap3-beagle.dtb omap3-beagle-xm.dtb"
26
27KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
28
29DEFAULT_PREFERENCE = "-1"
30
31S = "${WORKDIR}/git"
32
33BRANCH = "linux-3.14.y"
34
35# Corresponds to tag v3.14.43
36SRCREV = "13253707013a08ce5a279ebd029fa10230172458"
37PV = "3.14.43"
38
39SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git;protocol=git;branch=${BRANCH} \
40 file://defconfig \
41 "
diff --git a/recipes-kernel/linux/linux-ti-glsdk/defconfig b/recipes-kernel/linux/linux-ti-glsdk/defconfig
deleted file mode 100644
index 926b35a5..00000000
--- a/recipes-kernel/linux/linux-ti-glsdk/defconfig
+++ /dev/null
@@ -1 +0,0 @@
1use-kernel-config=omap2plus_defconfig
diff --git a/recipes-kernel/linux/linux-ti-glsdk_3.8.bb b/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
deleted file mode 100644
index 906da49c..00000000
--- a/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for TI devices supported by the GLSDK product"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5KERNEL_IMAGETYPE = "uImage"
6
7inherit kernel
8
9require recipes-kernel/linux/linux-dtb.inc
10require recipes-kernel/linux/setup-defconfig.inc
11
12KERNEL_DEVICETREE_omap5-evm = "omap5-uevm.dtb"
13KERNEL_DEVICETREE_dra7xx-evm = "dra7-evm.dtb"
14
15COMPATIBLE_MACHINE = "omap-a15"
16
17DEFAULT_PREFERENCE = "-1"
18
19S = "${WORKDIR}/git"
20
21BRANCH ?= "p-ti-glsdk-3.8.y"
22
23SRCREV ?= "cc16f99176bf083829c028f9af5b8eb560debcc1"
24PV = "3.8.13+git${SRCPV}"
25
26# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
27MACHINE_KERNEL_PR_append = "d"
28PR = "${MACHINE_KERNEL_PR}"
29
30SRC_URI = "git://git.omapzoom.org/kernel/omap.git;protocol=git;branch=${BRANCH} \
31 file://defconfig \
32 "
diff --git a/recipes-kernel/linux/linux-ti-staging-3.14/configs/systest b/recipes-kernel/linux/linux-ti-staging-3.14/configs/systest
deleted file mode 100644
index cfe4f991..00000000
--- a/recipes-kernel/linux/linux-ti-staging-3.14/configs/systest
+++ /dev/null
@@ -1 +0,0 @@
1use-combined-config=ti_config_fragments/system_test_defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging-3.14/defconfig b/recipes-kernel/linux/linux-ti-staging-3.14/defconfig
deleted file mode 100644
index 990e7f79..00000000
--- a/recipes-kernel/linux/linux-ti-staging-3.14/defconfig
+++ /dev/null
@@ -1 +0,0 @@
1use-combined-config=ti_config_fragments/defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging_3.14.bb b/recipes-kernel/linux/linux-ti-staging_3.14.bb
deleted file mode 100644
index 54530e4c..00000000
--- a/recipes-kernel/linux/linux-ti-staging_3.14.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for TI devices"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6inherit kernel
7
8require recipes-kernel/linux/linux-dtb.inc
9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/multi-kernel.inc
11require recipes-kernel/linux/cmem.inc
12
13# Look in the generic major.minor directory for files
14FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-3.14:"
15
16# Pull in the devicetree files into the rootfs
17RDEPENDS_kernel-base += "kernel-devicetree"
18
19# Add a run-time dependency for the PM firmware to be installed
20# on the target file system.
21RDEPENDS_kernel-base_append_ti33x = " am33x-cm3"
22RDEPENDS_kernel-base_append_ti43x = " am33x-cm3"
23
24# Add a run-time dependency for the VPE VPDMA firmware to be installed
25# on the target file system.
26RDEPENDS_kernel-base_append_dra7xx = " vpdma-fw"
27
28# Default is to package all dtb files for ti33x devices unless building
29# for the specific beaglebone machine.
30KERNEL_DEVICETREE_ti33x = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb am335x-boneblack.dtb"
31KERNEL_DEVICETREE_ti43x = "am43x-epos-evm.dtb am43x-epos-evm-hdmi.dtb am437x-gp-evm.dtb am437x-gp-evm-hdmi.dtb am437x-sk-evm.dtb"
32KERNEL_DEVICETREE_beaglebone = "am335x-bone.dtb am335x-boneblack.dtb"
33KERNEL_DEVICETREE_omap5-evm = "omap5-uevm.dtb"
34KERNEL_DEVICETREE_dra7xx-evm = "dra7-evm.dtb dra7-evm-lcd10.dtb dra72-evm.dtb dra72-evm-lcd10.dtb"
35KERNEL_DEVICETREE_am57xx-evm = "am57xx-beagle-x15.dtb am57xx-evm.dtb"
36KERNEL_DEVICETREE_omap3 = "omap3-beagle.dtb omap3-beagle-xm.dtb omap3-evm.dtb omap3-evm-37xx.dtb am3517-evm.dtb"
37KERNEL_DEVICETREE_am3517-evm = "am3517-evm.dtb"
38KERNEL_DEVICETREE_am37x-evm = "omap3-evm-37xx.dtb"
39KERNEL_DEVICETREE_beagleboard = "omap3-beagle.dtb omap3-beagle-xm.dtb"
40
41KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
42
43COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|omap3|omap4"
44
45S = "${WORKDIR}/git"
46
47BRANCH = "ti-linux-3.14.y"
48
49SRCREV = "e9cd4cc81906de385f1b04708860bb3142ea601a"
50PV = "3.14.49+git${SRCPV}"
51
52# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
53MACHINE_KERNEL_PR_append = "a"
54PR = "${MACHINE_KERNEL_PR}"
55
56KERNEL_CONFIG_DIR = "${S}/ti_config_fragments"
57
58KERNEL_CONFIG_FRAGMENTS_append_ti33x = " ${KERNEL_CONFIG_DIR}/am33xx_only.cfg"
59KERNEL_CONFIG_FRAGMENTS_append_ti43x = " ${KERNEL_CONFIG_DIR}/am43xx_only.cfg"
60
61MULTI_CONFIG_BASE_SUFFIX = ""
62
63KERNEL_GIT_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git"
64KERNEL_GIT_PROTOCOL = "git"
65SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
66 file://defconfig \
67 "
diff --git a/recipes-kernel/linux/multi-kernel.inc b/recipes-kernel/linux/multi-kernel.inc
deleted file mode 100644
index 0b7de915..00000000
--- a/recipes-kernel/linux/multi-kernel.inc
+++ /dev/null
@@ -1,140 +0,0 @@
1# This .inc file allows building and deploying multiple sets of kernel + modules
2# with different defconfigs
3#
4# Note that this include will NOT stage anything nor create packages, since that
5# is virtually impossible. Userspace should be built against the 'regular' kernel
6#
7# The intended usecase is for machines that have mutually exclusive drivers due
8# to e.g. pinmuxing issues. For example the LogicPD omap-l138 experimenter board
9# can have multiple mutually exclusive expansion boards like lcd, ethernet,
10# sound, 20x2 character LCD, etc. To be able to easily test all of those you can
11# use this .inc
12#
13# The function get_kernelversion uses generated header files to extract the
14# version number. But those files are not available until do_compile, and
15# do_compileconfigs is injected before that, hence the version becomes None
16# and breaks in several places. Introduce a task do_preparekernel that calls
17# "make prepare" in the kernel tree to generate all the necessary files.
18
19inherit deploy
20
21SRC_URI += " \
22 file://configs "
23
24def get_git_revision(p):
25 import subprocess
26
27 try:
28 return subprocess.Popen("git rev-parse HEAD 2>/dev/null ", cwd=p, shell=True, stdout=subprocess.PIPE).communicate()[0].rstrip()
29 except OSError:
30 return None
31
32KERNEL_LOCALVERSION = "-g${@get_git_revision('${S}').__str__()[:10]}"
33
34MULTI_CONFIG_BASE_SUFFIX = "multi-config-"
35
36KERNEL_IMAGE_BASE_NAME = "${KERNEL_IMAGETYPE}-${KERNEL_VERSION}-${PKGR}-${MACHINE}-${DATETIME}"
37MODULE_IMAGE_BASE_NAME = "modules-${KERNEL_VERSION}-${PKGR}-${MACHINE}-${DATETIME}"
38CONFIG_IMAGE_BASE_NAME = "config-${KERNEL_VERSION}-${PKGR}-${MACHINE}-${DATETIME}"
39
40EXTRA_OEMAKE = "${PARALLEL_MAKE} "
41
42do_preparekernel () {
43 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
44 oe_runmake prepare CC="${KERNEL_CC}" LD="${KERNEL_LD}"
45}
46
47addtask preparekernel after do_configure before do_compile
48
49do_compileconfigs () {
50 # fixup for fetcher change
51 if [ -e ${WORKDIR}/configs/configs ] ; then
52 if [ -e ${WORKDIR}/configs/configs/empty ] ; then
53 mv ${WORKDIR}/configs/configs/empty ${WORKDIR}/configs/
54 fi
55 mv ${WORKDIR}/configs/configs/* ${WORKDIR}/configs/
56 rm -rf ${WORKDIR}/configs/configs
57 fi
58
59 # Compile and Install additional kernel configs if found
60 if [ -e ${WORKDIR}/configs/empty ] ; then
61 echo "No configs found in configs/ directory, skipping to regular build"
62 else
63 echo "Multiple configs found, building those first"
64
65 # Context Save the regular 'defconfig'
66 cp ${WORKDIR}/defconfig ${WORKDIR}/defconfig.save
67
68 for configname in ${WORKDIR}/configs/* ; do
69 # Copy in alternative config
70 cd ${B}
71 cp $configname ${WORKDIR}/defconfig
72
73 # Build and Install this alternative kernel
74 do_configure
75 echo ${KERNEL_LOCALVERSION}-$(basename $configname) > ${B}/.scmversion
76 echo ${KERNEL_LOCALVERSION}-$(basename $configname) > ${S}/.scmversion
77 do_compile
78 do_compile_kernelmodules
79 # Below lines are needed to satisfy do_install and it's cleanup code, which doesn't know about configname
80 install -d "${D}/lib/modules/${KERNEL_VERSION}"
81 touch "${D}/lib/modules/${KERNEL_VERSION}/build"
82 touch "${D}/lib/modules/${KERNEL_VERSION}/source"
83 install -d "${D}/lib/modules/${KERNEL_VERSION}/kernel"
84 do_install
85
86 # Remove unused symlinks specific to configname
87 rm -f "${D}/lib/modules/$(cut -d\" -f2 ${B}/include/generated/utsrelease.h)/build"
88 rm -f "${D}/lib/modules/$(cut -d\" -f2 ${B}/include/generated/utsrelease.h)/source"
89 # In case no modules were installed, remove empty dirs
90 rmdir --ignore-fail-on-non-empty "${D}/lib/modules/$(cut -d\" -f2 ${B}/include/generated/utsrelease.h)/kernel"
91 rmdir --ignore-fail-on-non-empty "${D}/lib/modules/$(cut -d\" -f2 ${B}/include/generated/utsrelease.h)"
92 # Also remove default location for modules used by do_install if empty
93 rmdir --ignore-fail-on-non-empty "${D}/lib/modules/${KERNEL_VERSION}"
94
95 # Drop the resulting images in the deploy dir
96 install -d ${DEPLOYDIR}
97 install -m 0644 ${KERNEL_OUTPUT} ${DEPLOYDIR}/${KERNEL_IMAGE_BASE_NAME}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).bin
98
99 if [ -d "${D}/lib" ]; then
100 tar --owner=root --group=root -cvzf ${DEPLOYDIR}/${MODULE_IMAGE_BASE_NAME}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).tgz -C ${D} lib
101 fi
102
103 # Install the final config alongside the images
104 cp .config ${DEPLOYDIR}/${CONFIG_IMAGE_BASE_NAME}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).config
105
106 # Create symlinks
107 cd ${DEPLOYDIR}
108 rm -f ${KERNEL_IMAGE_SYMLINK_NAME}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).bin
109 ln -sf ${KERNEL_IMAGE_BASE_NAME}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).bin ${KERNEL_IMAGE_SYMLINK_NAME}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).bin
110 rm -f modules-${MACHINE}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).tgz
111 ln -sf ${MODULE_IMAGE_BASE_NAME}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).tgz modules-${MACHINE}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).tgz
112 rm -f config-${MACHINE}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).config
113 ln -sf ${CONFIG_IMAGE_BASE_NAME}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).config config-${MACHINE}.${MULTI_CONFIG_BASE_SUFFIX}$(basename $configname).config
114 done
115
116 # Restore the regular 'defconfig'
117 cp ${WORKDIR}/defconfig.save ${WORKDIR}/defconfig
118 cd ${B}
119 do_configure
120 fi
121}
122
123# For reference, copy .config to deploy image
124do_deploy_append () {
125 install -d ${DEPLOYDIR}
126
127 # Drop the regular defconfig along side the others for consistency
128 cp ${B}/.config ${DEPLOYDIR}/${CONFIG_IMAGE_BASE_NAME}.config
129
130 # add symlink
131 cd ${DEPLOYDIR}
132 rm -f config-${MACHINE}.config
133 ln -s ${CONFIG_IMAGE_BASE_NAME}.config config-${MACHINE}.config
134
135 rm -f modules-${MACHINE}.tgz
136 ln -sf ${MODULE_IMAGE_BASE_NAME}.tgz modules-${MACHINE}.tgz
137}
138
139do_compileconfigs[depends] += "u-boot-mkimage-native:do_populate_sysroot virtual/${TARGET_PREFIX}gcc:do_populate_sysroot"
140addtask compileconfigs after do_preparekernel before do_compile
diff --git a/recipes-kernel/linux/sitara-linux-ti-staging-3.14/defconfig b/recipes-kernel/linux/sitara-linux-ti-staging-3.14/defconfig
deleted file mode 100644
index 98c40690..00000000
--- a/recipes-kernel/linux/sitara-linux-ti-staging-3.14/defconfig
+++ /dev/null
@@ -1 +0,0 @@
1use-kernel-config=singlecore-omap2plus_defconfig
diff --git a/recipes-kernel/linux/sitara-linux-ti-staging_3.14.bb b/recipes-kernel/linux/sitara-linux-ti-staging_3.14.bb
deleted file mode 100644
index cc364463..00000000
--- a/recipes-kernel/linux/sitara-linux-ti-staging_3.14.bb
+++ /dev/null
@@ -1,51 +0,0 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for TI devices"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6inherit kernel
7
8require recipes-kernel/linux/linux-dtb.inc
9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/multi-kernel.inc
11
12# Look in the generic major.minor directory for files
13FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-3.14:"
14
15# Pull in the devicetree files into the rootfs
16RDEPENDS_kernel-base += "kernel-devicetree"
17
18# Add a run-time dependency for the PM firmware to be installed
19# on the target file system.
20RDEPENDS_kernel-base_append_ti33x = " am33x-cm3"
21RDEPENDS_kernel-base_append_ti43x = " am33x-cm3"
22
23
24# Default is to package all dtb files for ti33x devices unless building
25# for the specific beaglebone machine.
26KERNEL_DEVICETREE_ti33x = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb am335x-boneblack.dtb"
27KERNEL_DEVICETREE_ti43x = "am43x-epos-evm.dtb am43x-epos-evm-hdmi.dtb am437x-gp-evm.dtb am437x-gp-evm-hdmi.dtb am437x-sk-evm.dtb"
28KERNEL_DEVICETREE_beaglebone = "am335x-bone.dtb am335x-boneblack.dtb"
29
30KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
31
32COMPATIBLE_MACHINE = "ti33x|ti43x"
33
34S = "${WORKDIR}/git"
35
36BRANCH = "sitara-ti-linux-3.14.y"
37
38SRCREV = "2489c022b2932432606f897741a71b712e6dbe77"
39PV = "3.14.26+git${SRCPV}"
40
41# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
42MACHINE_KERNEL_PR_append = "h"
43PR = "${MACHINE_KERNEL_PR}"
44
45MULTI_CONFIG_BASE_SUFFIX = ""
46
47KERNEL_GIT_URI = "git://git.ti.com/sitara-linux/sitara-linux.git"
48KERNEL_GIT_PROTOCOL = "git"
49SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
50 file://defconfig \
51 "