summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-mainline_3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-mainline_3.2.bb')
-rw-r--r--recipes-kernel/linux/linux-mainline_3.2.bb90
1 files changed, 90 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-mainline_3.2.bb b/recipes-kernel/linux/linux-mainline_3.2.bb
new file mode 100644
index 00000000..efad8d01
--- /dev/null
+++ b/recipes-kernel/linux/linux-mainline_3.2.bb
@@ -0,0 +1,90 @@
1require linux.inc
2
3DESCRIPTION = "Linux kernel for TI processors"
4KERNEL_IMAGETYPE = "uImage"
5
6COMPATIBLE_MACHINE = "(beagleboard)"
7
8PV = "3.2.16"
9# v3.2.16 tag
10SRCREV_pn-${PN} = "b1be7dd1ec231ae751d0ce3acd0d2e5760704a6f"
11
12# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
13MACHINE_KERNEL_PR_append = "a"
14
15FILESPATH =. "${FILE_DIRNAME}/linux-mainline-3.2:${FILE_DIRNAME}/linux-mainline-3.2/${MACHINE}:"
16
17SRC_URI += "git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git;branch=linux-3.2.y;protocol=git \
18 file://distro/0001-kbuild-deb-pkg-set-host-machine-after-dpkg-gencontro.patch \
19 file://omap_cpufreq/0001-cpufreq-OMAP-cleanup-for-multi-SoC-support-move-into.patch \
20 file://omap_cpufreq/0002-cpufreq-OMAP-Add-SMP-support-for-OMAP4.patch \
21 file://omap_cpufreq/0003-cpufreq-OMAP-Enable-all-CPUs-in-shared-policy-mask.patch \
22 file://omap_cpufreq/0004-cpufreq-OMAP-notify-even-with-bad-boot-frequency.patch \
23 file://omap_cpufreq/0005-cpufreq-OMAP-move-clk-name-decision-to-init.patch \
24 file://omap_cpufreq/0006-cpufreq-OMAP-deny-initialization-if-no-mpudev.patch \
25 file://omap_cpufreq/0007-cpufreq-OMAP-dont-support-freq_table.patch \
26 file://omap_cpufreq/0008-cpufreq-OMAP-only-supports-OPP-library.patch \
27 file://omap_cpufreq/0009-cpufreq-OMAP-put-clk-if-cpu_init-failed.patch \
28 file://omap_cpufreq/0010-cpufreq-OMAP-fix-freq_table-leak.patch \
29 file://omap_cpufreq/0011-cpufreq-OMAP-fixup-for-omap_device-changes-include-l.patch \
30 file://micrel_zippy2/0001-ksz8851-eeprom-93cx6-add-drive_data.patch \
31 file://micrel_zippy2/0002-ksz8851-eeprom-93cx6-add-eeprom_93cx6_write.patch \
32 file://micrel_zippy2/0003-ksz8851-read_mac_addr.patch \
33 file://micrel_zippy2/0004-ksz8851-93cx6-eeprom-access.patch \
34 file://micrel_zippy2/0005-ks8851.h-it-helps-to-include-the-include-file.patch \
35 file://micrel_zippy2/0006-ksz8851-move-to-header.patch \
36 file://micrel_zippy2/0007-ksz8851-move-more-to-header.patch \
37 file://micrel_zippy2/0008-ksz8851-share-ks8851_tx_hdr-union.patch \
38 file://micrel_zippy2/0009-ksz8851-add-is_level_irq.patch \
39 file://micrel_zippy2/0010-ksz8851-turn-off-hardware-interrupt-druing-receive-p.patch \
40 file://micrel_zippy2/0011-ksz8851-make-sure-is-awake-before-writing-mac.patch \
41 file://micrel_zippy2/0012-ksz8851-add-mutex-lock-unlock-to-ks.patch \
42 file://micrel_zippy2/0013-ksz8851-add-ks8851_tx_check.patch \
43 file://micrel_zippy2/0014-ksz8851-move-ks8851_set_powermode.patch \
44 file://sakoman/0001-OMAP-DSS2-add-bootarg-for-selecting-svideo.patch \
45 file://sakoman/0002-video-add-timings-for-hd720.patch \
46 file://sakoman/0003-omap-mmc-Adjust-dto-to-eliminate-timeout-errors.patch \
47 file://beagle/0001-expansion-add-buddy-param-for-expansionboard-names.patch \
48 file://beagle/0002-expansion-add-mmc-regulator-and-ds1307-rtc.patch \
49 file://beagle/0003-expansion-add-zippy.patch \
50 file://beagle/0004-expansion-add-zippy2.patch \
51 file://beagle/0005-expansion-add-trainer.patch \
52 file://beagle/0006-expansion-add-ulcd.patch \
53 file://beagle/0007-beagleboard-reinstate-usage-of-hi-speed-PLL-divider.patch \
54 file://beagle/0008-Turn-on-the-USB-regulator-on-Beagle-xM-explicitly.patch \
55 file://beagle/0009-meego-modedb-add-Toshiba-LTA070B220F-800x480-support.patch \
56 file://beagle/0010-beagleboard-fix-uLCD7-support.patch \
57 file://beagle/0011-default-to-fifo-mode-5-for-old-musb-beagles.patch \
58 file://beagle/0012-backlight-Add-TLC59108-backlight-control-driver.patch \
59 file://beagle/0013-tlc59108-adjust-for-beagleboard-uLCD7.patch \
60 file://devkit8000/0001-arm-omap-devkit8000-for-lcd-use-samsung_lte_panel.patch \
61 file://touchbook/0001-omap3-touchbook-remove-mmc-gpio_wp.patch \
62 file://touchbook/0002-omap3-touchbook-drop-u-boot-readonly.patch \
63 file://panda/0001-panda-fix-wl12xx-regulator.patch \
64 file://panda/0002-panda-enable-bluetooth.patch \
65 file://panda/0003-ti-st-st-kim-fixing-firmware-path.patch \
66 file://omap_fixes/0001-omap3-Increase-limit-on-bootarg-mpurate.patch \
67 file://omap_fixes/0002-ARM-OMAP-AM3517-3505-fix-crash-on-boot-due-to-incorr.patch \
68 file://omap_fixes/0003-ARM-OMAP4-hwmod-Don-t-wait-for-the-idle-status-if-mo.patch \
69 file://omap_fixes/0004-ARM-OMAP4-clock-Add-CPU-local-timer-clock-node.patch \
70 file://omap_fixes/0005-ARM-OMAP3-hwmod-data-disable-multiblock-reads-on-MMC.patch \
71 file://omap_fixes/0006-OMAP-HWMOD-add-es3plus-to-am36xx-am35xx.patch \
72 \
73 file://defconfig"
74
75SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
76"
77
78S = "${WORKDIR}/git"
79
80# Sadly perf is broken:
81#| util/hist.c: In function '__hists__add_entry':
82#| util/hist.c:240:27: error: invalid type argument of '->' (have 'struct hist_entry')
83#| util/hist.c:241:23: error: invalid type argument of '->' (have 'struct hist_entry')
84do_compile_perf() {
85 :
86}
87
88do_install_perf() {
89 :
90}