summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch')
-rw-r--r--recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch b/recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch
new file mode 100644
index 00000000..8b7aa25a
--- /dev/null
+++ b/recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch
@@ -0,0 +1,32 @@
1From 607192f42d65e17f55fc6e85c00019bf71b18770 Mon Sep 17 00:00:00 2001
2From: Fathi Boudra <fathi.boudra@linaro.org>
3Date: Wed, 22 Mar 2017 19:47:32 +0200
4Subject: [PATCH 1/1] selftests: breakpoints: allow to cross-compile for
5 aarch64/arm64
6
7To build breakpoint_test_arm64, ARCH value is only tested for "aarch64".
8It covers only the native build because it's computed from uname -m output.
9For cross-compilation, ARCH is set to arm64 and prevent to cross-compile
10the test.
11Fix the test to allow both native and cross-compilation of the test.
12
13Note: glibc is missing several of the TRAP_* constants in the userspace
14 definitions. Specifically TRAP_BRANCH and TRAP_HWBKPT.
15 See https://sourceware.org/bugzilla/show_bug.cgi?id=21286
16
17Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
18---
19 tools/testing/selftests/breakpoints/Makefile | 2 +-
20 1 file changed, 1 insertion(+), 1 deletion(-)
21
22--- a/tools/testing/selftests/breakpoints/Makefile
23+++ b/tools/testing/selftests/breakpoints/Makefile
24@@ -5,7 +5,7 @@ ARCH ?= $(shell echo $(uname_M) | sed -e
25 ifeq ($(ARCH),x86)
26 TEST_PROGS := breakpoint_test
27 endif
28-ifeq ($(ARCH),aarch64)
29+ifneq (,$(filter $(ARCH),aarch64 arm64))
30 TEST_PROGS := breakpoint_test_arm64
31 endif
32