summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libgles/libgles-omap3_5.01.00.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/libgles/libgles-omap3_5.01.00.01.bb')
-rw-r--r--recipes-graphics/libgles/libgles-omap3_5.01.00.01.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes-graphics/libgles/libgles-omap3_5.01.00.01.bb b/recipes-graphics/libgles/libgles-omap3_5.01.00.01.bb
new file mode 100644
index 00000000..a3b34fe5
--- /dev/null
+++ b/recipes-graphics/libgles/libgles-omap3_5.01.00.01.bb
@@ -0,0 +1,50 @@
1require libgles-omap3-no-x.inc
2
3LICENSE = "TSPA"
4
5PR = "${INC_PR}.1"
6
7BINLOCATION_omap3 = "${S}/gfx_rel_es3.x"
8BINLOCATION_ti816x = "${S}/gfx_rel_es6.x"
9BINLOCATION_ti814x = "${S}/gfx_rel_es6.x"
10BINLOCATION_ti33x = "${S}/gfx_rel_es8.x"
11BINLOCATION_ti43x = "${S}/gfx_rel_es9.x"
12
13PLATFORM = "LinuxARMV7"
14PVR_INIT = "pvrsrvctl"
15
16SGXPV = "5_01_00_01"
17IMGPV = "1.10.2359475"
18
19TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}"
20
21BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin"
22MD5SUM_HARDFP = "0ee7d59808330d442a51c0990c2cb30e"
23SHA256SUM_HARDFP = "769daae439677a7a85bbbced14cee4f85b19823e0b99560078d0a864c525c128"
24
25# For now we only have hardfp version
26python __anonymous() {
27 tunes = bb.data.getVar("TUNE_FEATURES", d, 1)
28 if not tunes:
29 return
30 pkgn = bb.data.getVar("PN", d, 1)
31 pkgv = bb.data.getVar("PV", d, 1)
32 if "callconvention-hard" not in tunes:
33 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
34 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
35}
36
37BINFILE := "${BINFILE_HARDFP}"
38
39SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/gfxsdk/${SGXPV}/exports/${BINFILE} \
40 file://cputype \
41 file://rc.pvr \
42 file://99-bufferclass.rules \
43"
44
45SRC_URI[md5sum] := "${MD5SUM_HARDFP}"
46SRC_URI[sha256sum] := "${SHA256SUM_HARDFP}"
47
48S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
49
50LIBGLESWINDOWSYSTEM ?= "libpvrPVR2D_FRONTWSEGL.so.1"