summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb')
-rw-r--r--recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb46
1 files changed, 0 insertions, 46 deletions
diff --git a/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb b/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb
deleted file mode 100644
index 373dd9d2..00000000
--- a/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb
+++ /dev/null
@@ -1,46 +0,0 @@
1require libgles-omap3-no-x.inc
2
3LICENSE = "TI-TSPA"
4
5PR = "${INC_PR}.3"
6
7BINLOCATION_omap3 = "${S}/gfx_rel_es3.x"
8BINLOCATION_ti816x = "${S}/gfx_rel_es6.x"
9BINLOCATION_ti814x = "${S}/gfx_rel_es6.x"
10BINLOCATION_ti33x = "${S}/gfx_rel_es8.x"
11
12PLATFORM = "LinuxARMV7"
13PVR_INIT = "pvrsrvctl"
14
15# download required binary distribution from:
16# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
17# see libgles-omap3.inc for detailed installation instructions
18
19SGXPV = "4_09_00_01"
20IMGPV = "1.9.2188537"
21
22TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}"
23
24# Select the corresponding hardfp/softfp filename and checksums based on tune flags
25BINFILE_SOFTFP = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin"
26MD5SUM_SOFTFP = "bd35e9d8843aff3a2aca9d41e7db1c7d"
27SHA256SUM_SOFTFP = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249247647"
28
29BINFILE_HARDFP = "Graphics_SDK_setuplinux_${SGXPV}_hardfp_minimal_demos.bin"
30MD5SUM_HARDFP = "c9f656dce062d1ab10afffd4dfb71b67"
31SHA256SUM_HARDFP = "dbfeba8e1298f139495816334edec1455e6b49b1e11bd1b2aa0a888e5788bb6b"
32
33BINFILE = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${BINFILE_HARDFP}', '${BINFILE_SOFTFP}', d)}"
34
35SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
36 file://cputype \
37 file://rc.pvr \
38 file://99-bufferclass.rules \
39"
40
41SRC_URI[md5sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}"
42SRC_URI[sha256sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}"
43
44S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
45
46LIBGLESWINDOWSYSTEM ?= "libpvrPVR2D_FRONTWSEGL.so.1"