summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libgles/libgles-omap3_4.08.00.02.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/libgles/libgles-omap3_4.08.00.02.bb')
-rw-r--r--recipes-graphics/libgles/libgles-omap3_4.08.00.02.bb74
1 files changed, 0 insertions, 74 deletions
diff --git a/recipes-graphics/libgles/libgles-omap3_4.08.00.02.bb b/recipes-graphics/libgles/libgles-omap3_4.08.00.02.bb
deleted file mode 100644
index f4cd9aec..00000000
--- a/recipes-graphics/libgles/libgles-omap3_4.08.00.02.bb
+++ /dev/null
@@ -1,74 +0,0 @@
1require libgles-omap3.inc
2
3LICENSE = "TI-TSPA"
4
5BINLOCATION_omap3 = "${S}/gfx_rel_es3.x"
6BINLOCATION_ti816x = "${S}/gfx_rel_es6.x"
7BINLOCATION_ti814x = "${S}/gfx_rel_es6.x"
8BINLOCATION_ti33x = "${S}/gfx_rel_es8.x"
9
10PLATFORM = "LinuxARMV7"
11PVR_INIT = "pvrsrvctl"
12
13# download required binary distribution from:
14# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
15# see libgles-omap3.inc for detailed installation instructions
16
17SGXPV = "4_08_00_02"
18IMGPV = "1.9.2188537"
19BINFILE = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin"
20TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}"
21SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
22 file://cputype \
23 file://rc.pvr \
24 file://rc_dri.pvr \
25 file://sample.desktop \
26 file://99-bufferclass.rules \
27"
28
29SRC_URI[md5sum] = "0efa3a38266e6f41f8cc4fad0187f0d6"
30SRC_URI[sha256sum] = "c732044b515a598e1fab661b7463aa9c53d4fa37f4980dfa85cd02b7468d0cd9"
31
32S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
33
34LIBGLESWINDOWSYSTEM ?= "${@base_contains('DISTRO_FEATURES', 'x11',"libpvrPVR2D_DRIWSEGL.so" ,"libpvrPVR2D_FRONTWSEGL.so.1", d)}"
35
36do_configure_append() {
37
38 # Change PVR server's user mode library to point to DRI
39 for drifile in $(find ${S} -name "libsrv_um_dri.so"); do
40 if [ "$drifile" != "" ]
41 then
42 dir=$(dirname ${drifile})
43 if [ "$SUPPORT_XORG" = "1" ]
44 then
45 mv ${dir}/libsrv_um_dri.so ${dir}/libsrv_um.so
46 else
47 rm -rf ${dir}/libsrv_um_dri.so
48 fi
49 fi
50
51 done
52}
53
54do_install_append() {
55
56 # In this version of the graphics SDK the following directories do not exist:
57 # /GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/pvr2d.h (doesn't exist)
58 # /GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/GLES/egltypes.h (doesn't exist)
59 # Therefore, need to copy these files manually at the only location that they do exist
60 cp -pPr ${S}/include/pvr2d/*.h ${D}${includedir}
61 cp -pPr ${S}/include/OGLES/GLES ${D}${includedir}/
62
63 rm ${D}${sysconfdir}/init.d/pvr-init
64
65 if [ "$SUPPORT_XORG" = "1" ]; then
66 cp -pP ${WORKDIR}/rc_dri.pvr ${D}${sysconfdir}/init.d/pvr-init
67 else
68 cp -pP ${WORKDIR}/rc.pvr ${D}${sysconfdir}/init.d/pvr-init
69 fi
70
71}
72
73RRECOMMENDS_${PN}-x11demos = "${PN}-driwsegl"
74RRECOMMENDS_${PN}-x11trainingcourses = "${PN}-driwsegl"