summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb')
-rw-r--r--recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb90
1 files changed, 0 insertions, 90 deletions
diff --git a/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb b/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb
deleted file mode 100644
index 15aa8a67..00000000
--- a/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb
+++ /dev/null
@@ -1,90 +0,0 @@
1require libgles-omap3-x11.inc
2
3LICENSE = "TI-TSPA"
4
5PR = "${INC_PR}.3"
6
7DEFAULT_PREFERENCE = "-1"
8
9BINLOCATION_omap3 = "${S}/gfx_rel_es3.x"
10BINLOCATION_ti816x = "${S}/gfx_rel_es6.x"
11BINLOCATION_ti814x = "${S}/gfx_rel_es6.x"
12BINLOCATION_ti33x = "${S}/gfx_rel_es8.x"
13
14PLATFORM = "LinuxARMV7"
15PVR_INIT = "pvrsrvctl"
16
17# download required binary distribution from:
18# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
19# see libgles-omap3.inc for detailed installation instructions
20
21SGXPV = "4_09_00_01"
22IMGPV = "1.9.2188537"
23
24TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}"
25
26# Select the corresponding hardfp/softfp filename and checksums based on tune flags
27BINFILE_SOFTFP = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin"
28MD5SUM_SOFTFP = "bd35e9d8843aff3a2aca9d41e7db1c7d"
29SHA256SUM_SOFTFP = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249247647"
30
31BINFILE_HARDFP = "Graphics_SDK_setuplinux_${SGXPV}_hardfp_minimal_demos.bin"
32MD5SUM_HARDFP = "c9f656dce062d1ab10afffd4dfb71b67"
33SHA256SUM_HARDFP = "dbfeba8e1298f139495816334edec1455e6b49b1e11bd1b2aa0a888e5788bb6b"
34
35BINFILE = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${BINFILE_HARDFP}', '${BINFILE_SOFTFP}', d)}"
36
37SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
38 file://cputype \
39 file://rc.pvr \
40 file://rc_dri.pvr \
41 file://sample.desktop \
42 file://99-bufferclass.rules \
43"
44
45SRC_URI[md5sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}"
46SRC_URI[sha256sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}"
47
48S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
49
50LIBGLESWINDOWSYSTEM ?= "libpvrPVR2D_DRIWSEGL.so"
51
52do_configure_append() {
53
54 # Change PVR server's user mode library to point to DRI
55 for drifile in $(find ${S} -name "libsrv_um_dri.so"); do
56 if [ "$drifile" != "" ]
57 then
58 dir=$(dirname ${drifile})
59 if [ "$SUPPORT_XORG" = "1" ]
60 then
61 mv ${dir}/libsrv_um_dri.so ${dir}/libsrv_um.so
62 else
63 rm -rf ${dir}/libsrv_um_dri.so
64 fi
65 fi
66
67 done
68}
69
70do_install_append() {
71
72 # In this version of the graphics SDK the following directories do not exist:
73 # /GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/pvr2d.h (doesn't exist)
74 # /GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/GLES/egltypes.h (doesn't exist)
75 # Therefore, need to copy these files manually at the only location that they do exist
76 cp -pPr ${S}/include/pvr2d/*.h ${D}${includedir}
77 cp -pPr ${S}/include/OGLES/GLES ${D}${includedir}/
78
79 rm -f ${D}${sysconfdir}/init.d/pvr-init
80
81 if [ "$SUPPORT_XORG" = "1" ]; then
82 cp -pP ${WORKDIR}/rc_dri.pvr ${D}${sysconfdir}/init.d/pvr-init
83 else
84 cp -pP ${WORKDIR}/rc.pvr ${D}${sysconfdir}/init.d/pvr-init
85 fi
86
87}
88
89RRECOMMENDS_${PN}-x11demos = "${PN}-driwsegl"
90RRECOMMENDS_${PN}-x11trainingcourses = "${PN}-driwsegl"