summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb')
-rw-r--r--recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb b/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb
new file mode 100644
index 00000000..1c70cae6
--- /dev/null
+++ b/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb
@@ -0,0 +1,75 @@
1require libgles-omap3-x11.inc
2
3LICENSE = "TSPA"
4
5DEFAULT_PREFERENCE = "-1"
6
7BINLOCATION_omap3 = "${S}/gfx_rel_es3.x"
8BINLOCATION_ti816x = "${S}/gfx_rel_es6.x"
9BINLOCATION_ti814x = "${S}/gfx_rel_es6.x"
10BINLOCATION_ti33x = "${S}/gfx_rel_es8.x"
11
12PLATFORM = "LinuxARMV7"
13PVR_INIT = "pvrsrvctl"
14
15# download required binary distribution from:
16# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
17# see libgles-omap3.inc for detailed installation instructions
18
19SGXPV = "4_09_00_01"
20IMGPV = "1.9.2188537"
21BINFILE = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin"
22TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}"
23SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
24 file://cputype \
25 file://rc.pvr \
26 file://rc_dri.pvr \
27 file://sample.desktop \
28 file://99-bufferclass.rules \
29"
30SRC_URI[md5sum] = "bd35e9d8843aff3a2aca9d41e7db1c7d"
31SRC_URI[sha256sum] = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249247647"
32
33S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
34
35LIBGLESWINDOWSYSTEM ?= "libpvrPVR2D_DRIWSEGL.so"
36
37do_configure_append() {
38
39 # Change PVR server's user mode library to point to DRI
40 for drifile in $(find ${S} -name "libsrv_um_dri.so"); do
41 if [ "$drifile" != "" ]
42 then
43 dir=$(dirname ${drifile})
44 if [ "$SUPPORT_XORG" = "1" ]
45 then
46 mv ${dir}/libsrv_um_dri.so ${dir}/libsrv_um.so
47 else
48 rm -rf ${dir}/libsrv_um_dri.so
49 fi
50 fi
51
52 done
53}
54
55do_install_append() {
56
57 # In this version of the graphics SDK the following directories do not exist:
58 # /GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/pvr2d.h (doesn't exist)
59 # /GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/GLES/egltypes.h (doesn't exist)
60 # Therefore, need to copy these files manually at the only location that they do exist
61 cp -pPr ${S}/include/pvr2d/*.h ${D}${includedir}
62 cp -pPr ${S}/include/OGLES/GLES ${D}${includedir}/
63
64 rm ${D}${sysconfdir}/init.d/pvr-init
65
66 if [ "$SUPPORT_XORG" = "1" ]; then
67 cp -pP ${WORKDIR}/rc_dri.pvr ${D}${sysconfdir}/init.d/pvr-init
68 else
69 cp -pP ${WORKDIR}/rc.pvr ${D}${sysconfdir}/init.d/pvr-init
70 fi
71
72}
73
74RRECOMMENDS_${PN}-x11demos = "${PN}-driwsegl"
75RRECOMMENDS_${PN}-x11trainingcourses = "${PN}-driwsegl"