summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch')
-rw-r--r--recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch b/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch
new file mode 100644
index 00000000..bf63ed32
--- /dev/null
+++ b/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch
@@ -0,0 +1,48 @@
1From 51eece2c291e121f9ae67c9b812617b885e76a64 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 18 Dec 2019 20:31:52 -0800
4Subject: [PATCH] cmake: Use GNUInstallDirs module to detect install paths
5
6This helps it to calculate directories as per platform instead of
7hardcoding them, helps compile it for arches which use /lib64 and
8/usr/lib64 for libpaths
9
10Upstream-Status: Submitted [https://github.com/glneo/libion/pull/2]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 CMakeLists.txt | 10 ++++++----
14 1 file changed, 6 insertions(+), 4 deletions(-)
15
16diff --git a/CMakeLists.txt b/CMakeLists.txt
17index 6e5928c..5b7c0de 100644
18--- a/CMakeLists.txt
19+++ b/CMakeLists.txt
20@@ -3,6 +3,8 @@ PROJECT(ion)
21 set(PROJECT_DESCRIPTION "ION Userspace Memory Allocator Library")
22 set(PROJECT_VERSION 1.0.0)
23
24+INCLUDE(GNUInstallDirs)
25+
26 add_library(ion
27 SHARED
28 src/libion.c
29@@ -23,12 +25,12 @@ target_include_directories(ion
30 configure_file(libion.pc.in libion.pc @ONLY)
31
32 install(TARGETS ion
33- LIBRARY DESTINATION lib
34- PUBLIC_HEADER DESTINATION include/ion)
35+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
36+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/ion)
37
38 install(DIRECTORY include/kernel-headers/4.19/
39- DESTINATION include
40+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
41 FILES_MATCHING PATTERN "*.h")
42
43 install(FILES ${CMAKE_BINARY_DIR}/libion.pc
44- DESTINATION lib/pkgconfig)
45+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
46--
472.24.1
48