summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/gdbc6x/gdbc6x_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/gdbc6x/gdbc6x_git.bb')
-rw-r--r--recipes-devtools/gdbc6x/gdbc6x_git.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-devtools/gdbc6x/gdbc6x_git.bb b/recipes-devtools/gdbc6x/gdbc6x_git.bb
new file mode 100644
index 00000000..0e6a907c
--- /dev/null
+++ b/recipes-devtools/gdbc6x/gdbc6x_git.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "GNU debugger for TI C6X DSP."
2SECTION = "devel"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=bf0fe2872eb3dfeebb2cbe38206fe81f"
5
6DEPENDS = "ncurses bison texinfo flex gettext"
7
8PR = "${INC_PR}.0"
9
10SRC_URI_append = " \
11 file://init \
12"
13
14S = "${WORKDIR}/git/gdbc6x"
15
16inherit update-rc.d
17inherit gettext
18
19do_configure () {
20 cd ${S}
21 ./configure --program-suffix=c6x --target=tic6x-elf-tirtos --host=${HOST_SYS} --prefix=${S}/install_gdb
22}
23
24do_install () {
25 make install
26
27 # Custom install to prevent conflict with standard GDB.
28 install -d ${D}${bindir}
29 install -d ${D}${includedir}
30 install -m 755 ${S}/install_gdb/bin/gdbc6x ${D}${bindir}
31 cp -rf ${S}/install_gdb/include/* ${D}${includedir}
32
33 install -d ${D}${sysconfdir}/init.d
34 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/gdbserverproxy
35}
36
37RDEPENDS_${PN} = "gdbserverproxy-module-drv"
38
39include gdbc6x.inc
40
41INITSCRIPT_NAME = "gdbserverproxy"
42INITSCRIPT_PARAMS = "defaults 95"
43
44PARALLEL_MAKE = ""