diff options
Diffstat (limited to 'recipes-connectivity')
-rw-r--r-- | recipes-connectivity/uim/uim_8.5.bb | 22 | ||||
-rw-r--r-- | recipes-connectivity/uim/uim_git.bb | 19 |
2 files changed, 22 insertions, 19 deletions
diff --git a/recipes-connectivity/uim/uim_8.5.bb b/recipes-connectivity/uim/uim_8.5.bb new file mode 100644 index 00000000..ac9dc51c --- /dev/null +++ b/recipes-connectivity/uim/uim_8.5.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | DESCRIPTION = "Shared Transport Line Discipline User Mode initialisation Manager Daemon" | ||
2 | LICENSE = "GPLv2+" | ||
3 | LIC_FILES_CHKSUM = "file://uim.c;beginline=1;endline=18;md5=9f0bbfbc10c67689e81a523e2976c31e" | ||
4 | |||
5 | INITSCRIPT_NAME = "uim-sysfs" | ||
6 | INITSCRIPT_PARAMS = "defaults 03" | ||
7 | |||
8 | inherit update-rc.d | ||
9 | |||
10 | SRCREV = "a75f45be2d5c74fc1dd913d08afc30f09a230aa9" | ||
11 | SRC_URI = "git://git.ti.com/ti-bt/uim.git" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | EXTRA_OEMAKE = "CC=${TARGET_PREFIX}gcc" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${bindir} | ||
19 | install -m 0755 uim ${D}${bindir} | ||
20 | install -d ${D}${sysconfdir}/init.d | ||
21 | install -m 0755 scripts/uim-sysfs ${D}${sysconfdir}/init.d | ||
22 | } | ||
diff --git a/recipes-connectivity/uim/uim_git.bb b/recipes-connectivity/uim/uim_git.bb deleted file mode 100644 index c8265e92..00000000 --- a/recipes-connectivity/uim/uim_git.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | DESCRIPTION = "User Mode Initialization Manager for wl12xx devices" | ||
2 | LICENSE = "GPLv2+" | ||
3 | LIC_FILES_CHKSUM = "file://uim.c;startline=4;endline=12;md5=16a9d6e829218481f8a61797fe2be2e2" | ||
4 | |||
5 | # Doesn't have a version, so we'll make one up | ||
6 | PV = "0.0" | ||
7 | |||
8 | SRCREV = "c73894456df5def97111cb33d2106b684b8b7959" | ||
9 | SRC_URI = "git://gitorious.org/uim/uim.git" | ||
10 | |||
11 | S= "${WORKDIR}/git" | ||
12 | |||
13 | do_install() { | ||
14 | oe_runmake install DESTDIR=${D} | ||
15 | } | ||
16 | |||
17 | # connman has a plugin to handle all this | ||
18 | RCONFLICTS_${PN} += "connman-plugin-tist" | ||
19 | RRECOMMENDS_${PN} = "linux-firmware-wl12xx" | ||