summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/iolink-lld/iolink-lld-rtos_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/iolink-lld/iolink-lld-rtos_git.bb b/recipes-bsp/iolink-lld/iolink-lld-rtos_git.bb
new file mode 100644
index 00000000..c0c27b60
--- /dev/null
+++ b/recipes-bsp/iolink-lld/iolink-lld-rtos_git.bb
@@ -0,0 +1,33 @@
1SUMMARY = "TI RTOS low level driver for IO-Link Master"
2
3inherit ti-pdk ti-pdk-fetch
4
5TI_PDK_COMP = "ti.drv.iolink"
6
7PE = "1"
8
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://IOLINK.h;beginline=1;endline=32;md5=da669339a4b8594ed3edbe7ca30c726e"
11
12COMPATIBLE_MACHINE = "ti43x"
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15PR = "r2"
16
17DEPENDS_append = " osal-rtos \
18"
19DEPENDS_append_ti43x = " starterware-rtos \
20 pruss-lld-rtos \
21"
22
23# Build with make instead of XDC
24TI_PDK_XDCMAKE = "0"
25
26
27export PDK_IOLINK_ROOT_PATH ="${WORKDIR}/build"
28export DEST_ROOT="${S}"
29
30INSANE_SKIP_${PN} = "arch"
31
32# HTML doc link params
33PDK_COMP_LINK_TEXT = "IOLINK LLD"