diff options
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/utils-rtos/profiling-rtos_git.bb | 18 | ||||
-rw-r--r-- | recipes-bsp/utils-rtos/trace-rtos_git.bb | 18 |
2 files changed, 10 insertions, 26 deletions
diff --git a/recipes-bsp/utils-rtos/profiling-rtos_git.bb b/recipes-bsp/utils-rtos/profiling-rtos_git.bb index 134a0f9b..9846804d 100644 --- a/recipes-bsp/utils-rtos/profiling-rtos_git.bb +++ b/recipes-bsp/utils-rtos/profiling-rtos_git.bb | |||
@@ -1,6 +1,10 @@ | |||
1 | SUMMARY = "TI RTOS profiling utilities" | 1 | SUMMARY = "TI RTOS profiling utilities" |
2 | 2 | ||
3 | inherit ti-pdk | 3 | inherit ti-pdk ti-pdk-fetch |
4 | |||
5 | TI_PDK_COMP = "ti.utils.profiling" | ||
6 | |||
7 | PE = "1" | ||
4 | 8 | ||
5 | LICENSE = "BSD-3-Clause" | 9 | LICENSE = "BSD-3-Clause" |
6 | LIC_FILES_CHKSUM = "file://profilingver.h;beginline=1;endline=46;md5=974494ad60f33cfc0340e421c5a5a7a0" | 10 | LIC_FILES_CHKSUM = "file://profilingver.h;beginline=1;endline=46;md5=974494ad60f33cfc0340e421c5a5a7a0" |
@@ -8,21 +12,9 @@ LIC_FILES_CHKSUM = "file://profilingver.h;beginline=1;endline=46;md5=974494ad60f | |||
8 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|k3" | 12 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|k3" |
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 13 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
10 | 14 | ||
11 | PROFILING_GIT_URI = "git://git.ti.com/keystone-rtos/utils.git" | ||
12 | PROFILING_GIT_PROTOCOL = "git" | ||
13 | PROFILING_GIT_BRANCH = "master" | ||
14 | |||
15 | # Below commit ID corresponds to "DEV.UTILS.01.00.00.10" | ||
16 | PROFILING_SRCREV = "dbd2683d80326165d078282b1ef7dce44667e972" | ||
17 | |||
18 | BRANCH = "${PROFILING_GIT_BRANCH}" | ||
19 | SRC_URI = "${PROFILING_GIT_URI};protocol=${PROFILING_GIT_PROTOCOL};branch=${BRANCH}" | ||
20 | 15 | ||
21 | SRCREV = "${PROFILING_SRCREV}" | ||
22 | PV = "01.00.00.10" | ||
23 | PR = "r0" | 16 | PR = "r0" |
24 | 17 | ||
25 | S = "${WORKDIR}/git/profiling" | ||
26 | 18 | ||
27 | # Build with make instead of XDC | 19 | # Build with make instead of XDC |
28 | TI_PDK_XDCMAKE = "0" | 20 | TI_PDK_XDCMAKE = "0" |
diff --git a/recipes-bsp/utils-rtos/trace-rtos_git.bb b/recipes-bsp/utils-rtos/trace-rtos_git.bb index 48b3bf24..249ffc79 100644 --- a/recipes-bsp/utils-rtos/trace-rtos_git.bb +++ b/recipes-bsp/utils-rtos/trace-rtos_git.bb | |||
@@ -2,7 +2,11 @@ SUMMARY = "TI RTOS Trace utility" | |||
2 | 2 | ||
3 | DESCRIPTION = "This utility allows for tracing support in PDK drivers" | 3 | DESCRIPTION = "This utility allows for tracing support in PDK drivers" |
4 | 4 | ||
5 | inherit ti-pdk | 5 | inherit ti-pdk ti-pdk-fetch |
6 | |||
7 | TI_PDK_COMP = "ti.utils.trace" | ||
8 | |||
9 | PE = "1" | ||
6 | 10 | ||
7 | LICENSE = "BSD-3-Clause" | 11 | LICENSE = "BSD-3-Clause" |
8 | LIC_FILES_CHKSUM = "file://tracever.h;beginline=19;endline=47;md5=983f531ecfc9fc8c4bc3af9333ab6696" | 12 | LIC_FILES_CHKSUM = "file://tracever.h;beginline=19;endline=47;md5=983f531ecfc9fc8c4bc3af9333ab6696" |
@@ -10,21 +14,9 @@ LIC_FILES_CHKSUM = "file://tracever.h;beginline=19;endline=47;md5=983f531ecfc9fc | |||
10 | COMPATIBLE_MACHINE = "k3" | 14 | COMPATIBLE_MACHINE = "k3" |
11 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 15 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
12 | 16 | ||
13 | TRACE_GIT_URI = "git://git.ti.com/keystone-rtos/utils.git" | ||
14 | TRACE_GIT_PROTOCOL = "git" | ||
15 | TRACE_GIT_BRANCH = "master" | ||
16 | |||
17 | # Below commit ID corresponds to "DEV.UTILS.01.00.00.09" | ||
18 | TRACE_SRCREV = "84802d7a787a53f33a24254069c90208c5d87d1e" | ||
19 | |||
20 | BRANCH = "${TRACE_GIT_BRANCH}" | ||
21 | SRC_URI = "${TRACE_GIT_URI};protocol=${TRACE_GIT_PROTOCOL};branch=${BRANCH}" | ||
22 | 17 | ||
23 | SRCREV = "${TRACE_SRCREV}" | ||
24 | PV = "01.00.00.09" | ||
25 | PR = "r0" | 18 | PR = "r0" |
26 | 19 | ||
27 | S = "${WORKDIR}/git/trace" | ||
28 | 20 | ||
29 | # Build with make instead of XDC | 21 | # Build with make instead of XDC |
30 | TI_PDK_XDCMAKE = "0" | 22 | TI_PDK_XDCMAKE = "0" |