summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/srss-tc/srss-tc_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-bsp/srss-tc/srss-tc_git.bb b/recipes-bsp/srss-tc/srss-tc_git.bb
new file mode 100644
index 00000000..79edbed6
--- /dev/null
+++ b/recipes-bsp/srss-tc/srss-tc_git.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "TI Smart Reflex temperature control application for KeyStone II"
2HOMEPAGE = "http://git.ti.com/cgit/cgit.cgi/keystone-linux/srss-tc.git"
3LICENSE = "BSD & MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2c17cd1dc60dc06a4c4f2a2c45472a51"
5COMPATIBLE_MACHINE = "keystone"
6
7PV = "1.0.0.0"
8
9BRANCH = "master"
10# This commit corresponds to tag DEV.SRSS-TC-01.00.00.00A
11SRCREV = "7aaf8308d7ba470144730275df12edae5007e07a"
12
13SRC_URI = "git://git.ti.com/keystone-linux/srss-tc.git;protocol=git;branch=${BRANCH}"
14
15S = "${WORKDIR}/git"
16
17SRSS_BIN_NAME = "srss_tc.out"
18INITSCRIPT_NAME = "run_srss_tc.sh"
19INITSCRIPT_PARAMS = "defaults 10"
20
21inherit update-rc.d
22LDFLAGS += "-lrt"
23
24do_install() {
25 install -d ${D}${bindir}/
26 install -c -m 755 ${S}/src/${SRSS_BIN_NAME} ${D}${bindir}/${SRSS_BIN_NAME}
27
28 install -d ${D}${sysconfdir}/init.d/
29 install -c -m 755 ${S}/scripts/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
30}