summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/dfe-lld/dfe-lld-test_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-bsp/dfe-lld/dfe-lld-test_git.bb b/recipes-bsp/dfe-lld/dfe-lld-test_git.bb
new file mode 100644
index 00000000..acaaf637
--- /dev/null
+++ b/recipes-bsp/dfe-lld/dfe-lld-test_git.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "TI Digital Radio Front End lld test application"
2
3DEPENDS = "common-csl-ip dfe-lld iqn2-lld"
4
5include dfe-lld.inc
6
7EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} DFE_SRC_DIR=${S}"
8
9do_compile () {
10# Now build the lld in the updated directory
11 oe_runmake clean DEVICE=k2l
12 oe_runmake tests DEVICE=k2l
13 oe_runmake tests DEVICE=k2l USEDYNAMIC_LIB=yes
14}
15
16do_install () {
17 oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}/${bindir}
18}