summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch4
-rw-r--r--recipes-bsp/u-boot/u-boot/0002-am335x_evm-reduced-bootdelay-to-0.patch35
-rw-r--r--recipes-bsp/u-boot/u-boot/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch34
-rw-r--r--recipes-bsp/u-boot/u-boot/0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch64
-rw-r--r--recipes-bsp/u-boot/u-boot/0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch27
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb6
6 files changed, 167 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch b/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch
index af7fae72..3f030565 100644
--- a/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch
+++ b/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch
@@ -1,7 +1,7 @@
1From 5db18d5efdbdcd52ab33e28929a30f743a202bf8 Mon Sep 17 00:00:00 2001 1From 8bf8cbead1115e2a47b74f53b96272bbacad0df2 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 7 Oct 2011 18:17:50 +0200 3Date: Fri, 7 Oct 2011 18:17:50 +0200
4Subject: [PATCH] am335x-evm: hack in ethernet rmii clock 4Subject: [PATCH 1/5] am335x-evm: hack in ethernet rmii clock
5 5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> 6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7--- 7---
diff --git a/recipes-bsp/u-boot/u-boot/0002-am335x_evm-reduced-bootdelay-to-0.patch b/recipes-bsp/u-boot/u-boot/0002-am335x_evm-reduced-bootdelay-to-0.patch
new file mode 100644
index 00000000..b93d7046
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/0002-am335x_evm-reduced-bootdelay-to-0.patch
@@ -0,0 +1,35 @@
1From 8c7d293dcbf1bb53c4e8f26fc2553e99880978d1 Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com>
3Date: Sat, 8 Oct 2011 15:48:57 -0400
4Subject: [PATCH 2/5] am335x_evm: reduced bootdelay to 0
5
6---
7 include/configs/am335x_evm.h | 5 +----
8 1 files changed, 1 insertions(+), 4 deletions(-)
9
10diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
11index 0f806aa..c5e608c 100755
12--- a/include/configs/am335x_evm.h
13+++ b/include/configs/am335x_evm.h
14@@ -24,7 +24,7 @@
15 #define CONFIG_AM335X_HSMMC_INSTANCE 0 /* 0 - MMC0, 1 - MMC1 */
16
17 /* set to negative value for no autoboot */
18-#define CONFIG_BOOTDELAY 3
19+#define CONFIG_BOOTDELAY 0
20
21 # if defined(CONFIG_SPI_BOOT)
22 # define CONFIG_SPI 1
23@@ -73,9 +73,6 @@
24 #define CONFIG_SETUP_MEMORY_TAGS 1
25 #define CONFIG_INITRD_TAG 1 /* Required for ramdisk support */
26
27-/* set to negative value for no autoboot */
28-#define CONFIG_BOOTDELAY 3
29-
30 #define CONFIG_MMC 1
31
32 #ifndef CONFIG_NOR_BOOT
33--
341.6.6.1
35
diff --git a/recipes-bsp/u-boot/u-boot/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch b/recipes-bsp/u-boot/u-boot/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch
new file mode 100644
index 00000000..47fa7aa1
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch
@@ -0,0 +1,34 @@
1From 9de8f53dea91169f3b8a9473ad2b5c9c0fdd0eb1 Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com>
3Date: Sat, 8 Oct 2011 16:22:53 -0400
4Subject: [PATCH 3/5] am335x_evm: boot kernel from ext2 filesystem
5
6---
7 include/configs/am335x_evm.h | 4 +++-
8 1 files changed, 3 insertions(+), 1 deletions(-)
9
10diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
11index c5e608c..a2e4564 100755
12--- a/include/configs/am335x_evm.h
13+++ b/include/configs/am335x_evm.h
14@@ -112,7 +112,8 @@
15 "loadbootscript=fatload mmc 0 ${script_addr} boot.scr\0" \
16 "bootscript= echo Running bootscript from MMC/SD to set the ENV...; " \
17 "source ${script_addr}\0" \
18- "mmc_load_uimage=fatload mmc 0 ${loadaddr} ${bootfile}\0" \
19+ "mmc_load_uimage_fat=fatload mmc 0 ${loadaddr} ${bootfile}\0" \
20+ "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \
21 "bootargs_defaults=setenv bootargs " \
22 "console=${console}\0 " \
23 "mmc_args=run bootargs_defaults;" \
24@@ -403,6 +404,7 @@
25 # define CONFIG_CMD_MMC 1
26 # define CONFIG_DOS_PARTITION 1
27 # define CONFIG_CMD_FAT 1
28+# define CONFIG_CMD_EXT2 1
29 #endif
30
31 /* Unsupported features */
32--
331.6.6.1
34
diff --git a/recipes-bsp/u-boot/u-boot/0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch b/recipes-bsp/u-boot/u-boot/0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch
new file mode 100644
index 00000000..c8a05396
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch
@@ -0,0 +1,64 @@
1From abf7185e16b2b96db7aa06af56bd84836eff92f6 Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com>
3Date: Sat, 8 Oct 2011 16:20:50 -0400
4Subject: [PATCH 4/5] am335x_evm: read uEnv.txt instead of boot.scr
5
6Also restructured the BOOTCMD flow a bit to avoid pointless if/then depth.
7
8I'm considering to respect both boot.scr and uEnv.txt.
9---
10 include/configs/am335x_evm.h | 30 ++++++++++++++++++------------
11 1 files changed, 18 insertions(+), 12 deletions(-)
12
13diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
14index a2e4564..e157fd7 100755
15--- a/include/configs/am335x_evm.h
16+++ b/include/configs/am335x_evm.h
17@@ -112,6 +112,10 @@
18 "loadbootscript=fatload mmc 0 ${script_addr} boot.scr\0" \
19 "bootscript= echo Running bootscript from MMC/SD to set the ENV...; " \
20 "source ${script_addr}\0" \
21+ "bootenv=uEnv.txt\0" \
22+ "loadbootenv=fatload mmc 0 ${loadaddr} ${bootenv}\0" \
23+ "importbootenv=echo Importing environment from mmc ...; " \
24+ "env import -t $loadaddr $filesize\0" \
25 "mmc_load_uimage_fat=fatload mmc 0 ${loadaddr} ${bootfile}\0" \
26 "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \
27 "bootargs_defaults=setenv bootargs " \
28@@ -161,19 +165,21 @@
29 "bootm ${loadaddr}\0" \
30
31 #define CONFIG_BOOTCOMMAND \
32- "mw.l 0x44e10650 0x05 ; if mmc rescan; then " \
33- "if run loadbootscript; then " \
34- "run bootscript; " \
35- "else " \
36- "if run mmc_load_uimage; then " \
37- "run mmc_boot; " \
38- "else " \
39- "run nand_boot; " \
40- "fi; " \
41+ "mw.l 0x44e10650 0x05 ; " \
42+ "if mmc rescan; then " \
43+ "if run loadbootenv; then " \
44+ "echo Loaded environment from ${bootenv};" \
45+ "run importbootenv; " \
46 "fi; " \
47- "else " \
48- "run nand_boot; " \
49- "fi"
50+ "if test -n $uenvcmd; then " \
51+ "echo Running uenvcmd ...;" \
52+ "run uenvcmd;" \
53+ "fi;" \
54+ "if run mmc_load_uimage; then " \
55+ "run mmc_boot; " \
56+ "fi; " \
57+ "fi; " \
58+ "run nand_boot; " \
59
60 #define CONFIG_DISPLAY_BOARDINFO
61 #define CONFIG_MISC_INIT_R
62--
631.6.6.1
64
diff --git a/recipes-bsp/u-boot/u-boot/0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch b/recipes-bsp/u-boot/u-boot/0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch
new file mode 100644
index 00000000..6d484489
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch
@@ -0,0 +1,27 @@
1From 2f05cac97c5aba4d2dbd3e9ec6c53c8cbf27ee77 Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com>
3Date: Sat, 8 Oct 2011 16:57:08 -0400
4Subject: [PATCH 5/5] am335x_evm: remove redundant attempt to load uImage
5
6---
7 include/configs/am335x_evm.h | 4 +---
8 1 files changed, 1 insertions(+), 3 deletions(-)
9
10diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
11index e157fd7..cb69176 100755
12--- a/include/configs/am335x_evm.h
13+++ b/include/configs/am335x_evm.h
14@@ -175,9 +175,7 @@
15 "echo Running uenvcmd ...;" \
16 "run uenvcmd;" \
17 "fi;" \
18- "if run mmc_load_uimage; then " \
19- "run mmc_boot; " \
20- "fi; " \
21+ "run mmc_boot; " \
22 "fi; " \
23 "run nand_boot; " \
24
25--
261.6.6.1
27
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index 9aebb1bc..5607bd67 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -4,7 +4,7 @@ require u-boot.inc
4COMPATIBLE_MACHINE = "beaglebone" 4COMPATIBLE_MACHINE = "beaglebone"
5DEFAULT_PREFERENCE_beaglebone = "99" 5DEFAULT_PREFERENCE_beaglebone = "99"
6PV = "2011.09+git" 6PV = "2011.09+git"
7PR = "r2" 7PR = "r3"
8 8
9# SPL build 9# SPL build
10UBOOT_BINARY = "u-boot.img" 10UBOOT_BINARY = "u-boot.img"
@@ -13,6 +13,10 @@ UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
13 13
14SRC_URI = "git://github.com/joelagnel/u-boot.git;protocol=git;branch=bone-bringup \ 14SRC_URI = "git://github.com/joelagnel/u-boot.git;protocol=git;branch=bone-bringup \
15 file://0001-am335x-evm-hack-in-ethernet-rmii-clock.patch \ 15 file://0001-am335x-evm-hack-in-ethernet-rmii-clock.patch \
16 file://0002-am335x_evm-reduced-bootdelay-to-0.patch \
17 file://0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch \
18 file://0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch \
19 file://0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch \
16 " 20 "
17SRCREV = "d643e691ab2055ef64f73dd70300a73e0443d1ef" 21SRCREV = "d643e691ab2055ef64f73dd70300a73e0443d1ef"
18 22