diff options
Diffstat (limited to 'recipes-bsp/wl18xx-fw')
-rw-r--r-- | recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch | 29 | ||||
-rw-r--r-- | recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.1.bb | 26 |
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch b/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch new file mode 100644 index 00000000..a8db0770 --- /dev/null +++ b/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 3a8fc3ccf00796254d6cef4b6d4cd70dc37012e1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Fri, 10 Mar 2017 13:28:29 -0500 | ||
4 | Subject: [PATCH] Add Makefile to install firmware files | ||
5 | |||
6 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
7 | --- | ||
8 | Makefile | 9 +++++++++ | ||
9 | 1 file changed, 9 insertions(+) | ||
10 | create mode 100644 Makefile | ||
11 | |||
12 | diff --git a/Makefile b/Makefile | ||
13 | new file mode 100644 | ||
14 | index 0000000..1cf38e3 | ||
15 | --- /dev/null | ||
16 | +++ b/Makefile | ||
17 | @@ -0,0 +1,9 @@ | ||
18 | +# Installs the the ti-connectivity wlan firmware files into the root file system | ||
19 | + | ||
20 | +install: | ||
21 | + @if [ ! -d $(DESTDIR) ] ; then \ | ||
22 | + echo "Target filesystem directory doesn't exist."; \ | ||
23 | + exit 1; \ | ||
24 | + fi | ||
25 | + install -d $(DEST_DIR)/lib/firmware/ti-connectivity | ||
26 | + cp *.bin $(DEST_DIR)/lib/firmware/ti-connectivity/ | ||
27 | -- | ||
28 | 2.7.4 | ||
29 | |||
diff --git a/recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.1.bb b/recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.1.bb new file mode 100644 index 00000000..ec360fef --- /dev/null +++ b/recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.1.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | DESCRIPTION = "Firmware files for use with TI wl18xx" | ||
2 | LICENSE = "TI-TSPA" | ||
3 | LIC_FILES_CHKSUM = "file://LICENCE;md5=4977a0fe767ee17765ae63c435a32a9e" | ||
4 | |||
5 | SRC_URI = " \ | ||
6 | git://git.ti.com/wilink8-wlan/wl18xx_fw.git;protocol=git;branch=${BRANCH} \ | ||
7 | file://0001-Add-Makefile-to-install-firmware-files.patch \ | ||
8 | " | ||
9 | |||
10 | # Tag: R8.7-SP1 (8.7.1) | ||
11 | SRCREV = "fe3909e93d15a4b17e43699dde2bba0e9a3c0abc" | ||
12 | BRANCH = "master" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | CLEANBROKEN = "1" | ||
17 | |||
18 | do_compile() { | ||
19 | : | ||
20 | } | ||
21 | |||
22 | do_install() { | ||
23 | oe_runmake 'DEST_DIR=${D}' install | ||
24 | } | ||
25 | |||
26 | FILES_${PN} = "/lib/firmware/ti-connectivity/*" | ||