summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb')
-rw-r--r--recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb b/recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb
new file mode 100644
index 00000000..fb3012a7
--- /dev/null
+++ b/recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "VPE VPDMA firmware and test program"
2
3DEPENDS += "virtual/kernel"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=74d2f71d8898c54e3d1c9d0058c484aa"
7
8COMPATIBLE_MACHINE = "dra7xx-evm"
9
10PV = "1b8"
11PR = "r1"
12
13SRCREV = "e3d8db1aa935775f9d196ad7428e0cd9864a36ca"
14BRANCH ?= "master"
15
16SRC_URI = "git://git.ti.com/vpe_tests/vpe_tests.git;protocol=git;branch=${BRANCH}"
17
18S = "${WORKDIR}/git"
19
20# The test application needs additional include headers from the kernel
21EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" KDIR="${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"'
22
23do_install() {
24 oe_runmake DESTDIR="${D}" install
25}
26
27# Separate the firmware into it's own package.
28PACKAGES =+ "${PN}-fw"
29FILES_${PN}-fw += "${base_libdir}/firmware"