summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/vpe-tests
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/vpe-tests')
-rw-r--r--recipes-bsp/vpe-tests/vpe-tests_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/vpe-tests/vpe-tests_git.bb b/recipes-bsp/vpe-tests/vpe-tests_git.bb
new file mode 100644
index 00000000..a8ee7f89
--- /dev/null
+++ b/recipes-bsp/vpe-tests/vpe-tests_git.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "VPE test program"
2
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=74d2f71d8898c54e3d1c9d0058c484aa"
5
6COMPATIBLE_MACHINE = "dra7xx"
7
8SRCREV = "e3d8db1aa935775f9d196ad7428e0cd9864a36ca"
9BRANCH ?= "master"
10
11SRC_URI = "git://git.ti.com/vpe_tests/vpe_tests.git;protocol=git;branch=${BRANCH}"
12
13S = "${WORKDIR}/git"
14
15FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}"
16
17# The test application needs additional include headers from the kernel
18EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${TARGET_PREFIX}gcc ${FLOATABI}" KDIR="${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"'
19
20do_install() {
21 oe_runmake DESTDIR="${D}" install
22}
23