summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch49
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb3
2 files changed, 51 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch
new file mode 100644
index 00000000..f73d3c4e
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch
@@ -0,0 +1,49 @@
1From bd152bec1086a35f426c53c9bb9f0c309e216037 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 2 Nov 2011 19:07:10 +0100
4Subject: [PATCH 5/5] am335x: Change mmc_load_uimage to load at a fixed address
5 The kernel normally expects to be run from 0x80008000 so if we
6 load from SD card at that-mkimage header we can save a copy of
7 the kernel.
8
9Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
10---
11 include/configs/am335x_evm.h | 8 ++++----
12 1 files changed, 4 insertions(+), 4 deletions(-)
13
14diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
15index 56e36da..8c0fae2 100755
16--- a/include/configs/am335x_evm.h
17+++ b/include/configs/am335x_evm.h
18@@ -74,8 +74,8 @@
19 "loadbootenv=fatload mmc ${mmc_dev} ${loadaddr} ${bootenv}\0" \
20 "importbootenv=echo Importing environment from mmc ...; " \
21 "env import -t $loadaddr $filesize\0" \
22- "mmc_load_uimage_fat=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \
23- "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \
24+ "mmc_load_uimage_fat=fatload mmc ${mmc_dev} 0x80007fc0 ${bootfile}\0" \
25+ "mmc_load_uimage=ext2load mmc 0:2 0x80007fc0 /boot/${bootfile}\0" \
26 "optargs=\0" \
27 "bootargs_defaults=setenv bootargs " \
28 "console=${console} " \
29@@ -103,7 +103,7 @@
30 "ip=dhcp\0" \
31 "mmc_boot=run mmc_args; " \
32 "run mmc_load_uimage; " \
33- "bootm ${loadaddr}\0" \
34+ "bootm\0" \
35 "nand_boot=echo Booting from nand ...; " \
36 "run nand_args; " \
37 "nand read.i ${loadaddr} ${nand_src_addr} ${nand_img_siz}; " \
38@@ -137,7 +137,7 @@
39 "fi;" \
40 "if run mmc_load_uimage; then " \
41 "run mmc_args;" \
42- "bootm ${loadaddr};" \
43+ "bootm;" \
44 "fi;" \
45 "fi;" \
46 "run nand_boot;" \
47--
481.7.2.5
49
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index e4552b86..eda4a628 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -4,7 +4,7 @@ require u-boot.inc
4COMPATIBLE_MACHINE = "(ti33x)" 4COMPATIBLE_MACHINE = "(ti33x)"
5DEFAULT_PREFERENCE_ti33x = "99" 5DEFAULT_PREFERENCE_ti33x = "99"
6PV = "2011.09+git" 6PV = "2011.09+git"
7PR = "r16" 7PR = "r17"
8 8
9# SPL build 9# SPL build
10UBOOT_BINARY = "u-boot.img" 10UBOOT_BINARY = "u-boot.img"
@@ -16,6 +16,7 @@ SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;br
16 file://2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch \ 16 file://2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch \
17 file://2011.09git/0003-am335x_evm-set-bootdelay-to-1.patch \ 17 file://2011.09git/0003-am335x_evm-set-bootdelay-to-1.patch \
18 file://2011.09git/0004-am335x-evm-make-MMC-rootfs-RO-on-boot-so-fsck-works.patch \ 18 file://2011.09git/0004-am335x-evm-make-MMC-rootfs-RO-on-boot-so-fsck-works.patch \
19 file://2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch \
19 " 20 "
20 21
21SRCREV = "f63b270e47f62f4d1a05b2001357e215966c6f5a" 22SRCREV = "f63b270e47f62f4d1a05b2001357e215966c6f5a"