summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-sakoman_git.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch26
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch65
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch121
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch26
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch26
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.12.bb27
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb25
9 files changed, 296 insertions, 24 deletions
diff --git a/recipes-bsp/u-boot/u-boot-sakoman_git.bb b/recipes-bsp/u-boot/u-boot-sakoman_git.bb
index 5b9ff111..fab269a3 100644
--- a/recipes-bsp/u-boot/u-boot-sakoman_git.bb
+++ b/recipes-bsp/u-boot/u-boot-sakoman_git.bb
@@ -1,5 +1,7 @@
1require u-boot.inc 1require u-boot.inc
2 2
3COMPATIBLE_MACHINE = "omap4430-panda"
4
3FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-sakoman-git/" 5FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-sakoman-git/"
4 6
5SRCREV = "261733408a27d14590cf3ec6b596461808050e32" 7SRCREV = "261733408a27d14590cf3ec6b596461808050e32"
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch b/recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch
new file mode 100644
index 00000000..07ab75b1
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch
@@ -0,0 +1,26 @@
1From d0556964b6bd443e8b60d5c0b3326795a02cc8a7 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sun, 27 Nov 2011 14:43:58 +0100
4Subject: [PATCH 1/5] beagleboard: mount rootfs RO instead of RW at boot
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/omap3_beagle.h | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
12index 91af8a0..d4f33d0 100644
13--- a/include/configs/omap3_beagle.h
14+++ b/include/configs/omap3_beagle.h
15@@ -220,7 +220,7 @@
16 "dvimode=640x480MR-16@60\0" \
17 "defaultdisplay=dvi\0" \
18 "mmcdev=0\0" \
19- "mmcroot=/dev/mmcblk0p2 rw\0" \
20+ "mmcroot=/dev/mmcblk0p2 ro\0" \
21 "mmcrootfstype=ext3 rootwait\0" \
22 "nandroot=ubi0:rootfs ubi.mtd=4\0" \
23 "nandrootfstype=ubifs\0" \
24--
251.7.2.5
26
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch b/recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch
new file mode 100644
index 00000000..5af34a15
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch
@@ -0,0 +1,65 @@
1From 28e5cc1f13d817f75638c72eae853e53510a1ab2 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sat, 8 Oct 2011 21:56:35 +0200
4Subject: [PATCH 2/5] beagleboard: add support for TCT Beacon board
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 board/ti/beagle/beagle.c | 10 ++++++++++
9 board/ti/beagle/beagle.h | 7 +++++++
10 2 files changed, 17 insertions(+), 0 deletions(-)
11
12diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
13index 6a457cb..9c2e6d0 100644
14--- a/board/ti/beagle/beagle.c
15+++ b/board/ti/beagle/beagle.c
16@@ -59,11 +59,14 @@ extern volatile struct ehci_hcor *hcor;
17 #define TWL4030_I2C_BUS 0
18 #define EXPANSION_EEPROM_I2C_BUS 1
19 #define EXPANSION_EEPROM_I2C_ADDRESS 0x50
20+#define DVI_EDID_I2C_BUS 2
21+#define DVI_EDID_I2C_ADDRESS 0x50
22
23 #define TINCANTOOLS_ZIPPY 0x01000100
24 #define TINCANTOOLS_ZIPPY2 0x02000100
25 #define TINCANTOOLS_TRAINER 0x04000100
26 #define TINCANTOOLS_SHOWDOG 0x03000100
27+#define TINCANTOOLS_BEACON 0x05000100
28 #define KBADC_BEAGLEFPGA 0x01000600
29 #define LW_BEAGLETOUCH 0x01000700
30 #define BRAINMUX_LCDOG 0x01000800
31@@ -351,6 +354,13 @@ int misc_init_r(void)
32 setenv("defaultdisplay", "showdoglcd");
33 setenv("buddy", "showdog");
34 break;
35+ case TINCANTOOLS_BEACON:
36+ printf("Recognized Tincantools Beacon board (rev %d %s)\n",
37+ expansion_config.revision,
38+ expansion_config.fab_revision);
39+ MUX_TINCANTOOLS_BEACON();
40+ setenv("buddy", "beacon");
41+ break;
42 case KBADC_BEAGLEFPGA:
43 printf("Recognized KBADC Beagle FPGA board\n");
44 MUX_KBADC_BEAGLEFPGA();
45diff --git a/board/ti/beagle/beagle.h b/board/ti/beagle/beagle.h
46index 18bfaa8..6a9ad73 100644
47--- a/board/ti/beagle/beagle.h
48+++ b/board/ti/beagle/beagle.h
49@@ -456,6 +456,13 @@ const omap3_sysinfo sysinfo = {
50 MUX_VAL(CP(MCBSP3_CLKX), (IEN | PTU | EN | M4)) /*GPIO_141*/\
51 MUX_VAL(CP(MCBSP1_CLKX), (IEN | PTU | EN | M4)) /*GPIO_162*/
52
53+#define MUX_TINCANTOOLS_BEACON() \
54+ MUX_VAL(CP(MMC2_DAT3), (IEN | PTU | EN | M4)) /*GPIO_135*/\
55+ MUX_VAL(CP(MMC2_DAT4), (IEN | PTU | EN | M4)) /*GPIO_136*/\
56+ MUX_VAL(CP(MMC2_DAT5), (IEN | PTU | EN | M4)) /*GPIO_137*/\
57+ MUX_VAL(CP(MMC2_DAT6), (IEN | PTU | EN | M4)) /*GPIO_138*/\
58+ MUX_VAL(CP(MMC2_DAT7), (IEN | PTU | EN | M4)) /*GPIO_139*/\
59+
60 #define MUX_KBADC_BEAGLEFPGA() \
61 MUX_VAL(CP(MCBSP1_CLKR), (IEN | PTU | DIS | M1)) /*MCSPI4_CLK*/\
62 MUX_VAL(CP(MCBSP1_DX), (IDIS | PTU | DIS | M1)) /*MCSPI4_SIMO*/\
63--
641.7.2.5
65
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch b/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch
new file mode 100644
index 00000000..31c40639
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch
@@ -0,0 +1,121 @@
1From fe9c653a0b0a3fa49d269b697c2058a6a55aa42b Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sun, 27 Nov 2011 14:53:56 +0100
4Subject: [PATCH 3/5] beagleboard: add support for scanning loop-through expansionboards like the uLCD-lite
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 board/ti/beagle/beagle.c | 30 ++++++++++++++++++++++++++----
9 include/configs/omap3_beagle.h | 4 ++++
10 2 files changed, 30 insertions(+), 4 deletions(-)
11
12diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
13index 9c2e6d0..5ea50d1 100644
14--- a/board/ti/beagle/beagle.c
15+++ b/board/ti/beagle/beagle.c
16@@ -74,6 +74,7 @@ extern volatile struct ehci_hcor *hcor;
17 #define BBTOYS_WIFI 0x01000B00
18 #define BBTOYS_VGA 0x02000B00
19 #define BBTOYS_LCD 0x03000B00
20+#define BBTOYS_ULCD 0x04000B00
21 #define BEAGLE_NO_EEPROM 0xffffffff
22
23 DECLARE_GLOBAL_DATA_PTR;
24@@ -209,18 +210,18 @@ void get_board_mem_timings(u32 *mcfg, u32 *ctrla, u32 *ctrlb, u32 *rfr_ctrl,
25 * bus 1 for the availability of an AT24C01B serial EEPROM.
26 * returns the device_vendor field from the EEPROM
27 */
28-unsigned int get_expansion_id(void)
29+unsigned int get_expansion_id(int eeprom_address)
30 {
31 i2c_set_bus_num(EXPANSION_EEPROM_I2C_BUS);
32
33 /* return BEAGLE_NO_EEPROM if eeprom doesn't respond */
34- if (i2c_probe(EXPANSION_EEPROM_I2C_ADDRESS) == 1) {
35+ if (i2c_probe(eeprom_address) == 1) {
36 i2c_set_bus_num(TWL4030_I2C_BUS);
37 return BEAGLE_NO_EEPROM;
38 }
39
40 /* read configuration data */
41- i2c_read(EXPANSION_EEPROM_I2C_ADDRESS, 0, 1, (u8 *)&expansion_config,
42+ i2c_read(eeprom_address, 0, 1, (u8 *)&expansion_config,
43 sizeof(expansion_config));
44
45 i2c_set_bus_num(TWL4030_I2C_BUS);
46@@ -323,7 +324,7 @@ int misc_init_r(void)
47 TWL4030_PM_RECEIVER_DEV_GRP_P1);
48 }
49
50- switch (get_expansion_id()) {
51+ switch (get_expansion_id(EXPANSION_EEPROM_I2C_ADDRESS)) {
52 case TINCANTOOLS_ZIPPY:
53 printf("Recognized Tincantools Zippy board (rev %d %s)\n",
54 expansion_config.revision,
55@@ -402,6 +403,27 @@ int misc_init_r(void)
56 if (expansion_config.content == 1)
57 setenv(expansion_config.env_var, expansion_config.env_setting);
58
59+ /* Scan 0x51 as well for loop-thru boards */
60+ switch (get_expansion_id(EXPANSION_EEPROM_I2C_ADDRESS + 1)) {
61+ case BBTOYS_ULCD:
62+ printf("Recognized BeagleBoardToys uLCD-lite board\n");
63+ setenv("buddy2", "bbtoys-ulcd");
64+ setenv("defaultdisplay", "lcd");
65+ setenv("uenvcmd", "i2c dev 1 ; i2c mw 40 00 00; i2c mw 40 04 80; i2c mw 40 0d 05; i2c mw 40 0d 15");
66+ break;
67+ case BEAGLE_NO_EEPROM:
68+ printf("No EEPROM on expansion board\n");
69+ setenv("buddy2", "none");
70+ break;
71+ default:
72+ printf("Unrecognized expansion board: %x\n",
73+ expansion_config.device_vendor);
74+ setenv("buddy2", "unknown");
75+ }
76+
77+ if (expansion_config.content == 1)
78+ setenv(expansion_config.env_var, expansion_config.env_setting);
79+
80 twl4030_power_init();
81 switch (get_board_revision()) {
82 case REVISION_XM_A:
83diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
84index d4f33d0..65ab8ee 100644
85--- a/include/configs/omap3_beagle.h
86+++ b/include/configs/omap3_beagle.h
87@@ -214,6 +214,7 @@
88 "console=ttyO2,115200n8\0" \
89 "mpurate=auto\0" \
90 "buddy=none "\
91+ "buddy2=none "\
92 "optargs=\0" \
93 "camera=none\0" \
94 "vram=12M\0" \
95@@ -230,6 +231,7 @@
96 "${optargs} " \
97 "mpurate=${mpurate} " \
98 "buddy=${buddy} "\
99+ "buddy2=${buddy2} "\
100 "camera=${camera} "\
101 "vram=${vram} " \
102 "omapfb.mode=dvi:${dvimode} " \
103@@ -240,6 +242,7 @@
104 "${optargs} " \
105 "mpurate=${mpurate} " \
106 "buddy=${buddy} "\
107+ "buddy2=${buddy2} "\
108 "camera=${camera} "\
109 "vram=${vram} " \
110 "omapfb.mode=dvi:${dvimode} " \
111@@ -254,6 +257,7 @@
112 "${optargs} " \
113 "mpurate=${mpurate} " \
114 "buddy=${buddy} "\
115+ "buddy2=${buddy2} "\
116 "vram=${vram} " \
117 "omapfb.mode=dvi:${dvimode} " \
118 "omapdss.def_disp=${defaultdisplay} " \
119--
1201.7.2.5
121
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch b/recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch
new file mode 100644
index 00000000..0d3655d3
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch
@@ -0,0 +1,26 @@
1From 90dfb660575f15ba736884139f35bfd4ba927468 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 8 Dec 2011 17:22:59 +0100
4Subject: [PATCH 4/5] omap4-common: mount root RO
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/omap4_common.h | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/include/configs/omap4_common.h b/include/configs/omap4_common.h
12index a989721..54760e9 100644
13--- a/include/configs/omap4_common.h
14+++ b/include/configs/omap4_common.h
15@@ -154,7 +154,7 @@
16 "usbtty=cdc_acm\0" \
17 "vram=16M\0" \
18 "mmcdev=0\0" \
19- "mmcroot=/dev/mmcblk0p2 rw\0" \
20+ "mmcroot=/dev/mmcblk0p2 ro\0" \
21 "mmcrootfstype=ext3 rootwait\0" \
22 "mmcargs=setenv bootargs console=${console} " \
23 "vram=${vram} " \
24--
251.7.2.5
26
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch b/recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch
new file mode 100644
index 00000000..e28eae57
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch
@@ -0,0 +1,26 @@
1From a1f9453f2450762249aa35bd5ae97150acc53eb2 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 8 Dec 2011 17:23:24 +0100
4Subject: [PATCH 5/5] omap4-common: use ext4 by default
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/omap4_common.h | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/include/configs/omap4_common.h b/include/configs/omap4_common.h
12index 54760e9..7637688 100644
13--- a/include/configs/omap4_common.h
14+++ b/include/configs/omap4_common.h
15@@ -155,7 +155,7 @@
16 "vram=16M\0" \
17 "mmcdev=0\0" \
18 "mmcroot=/dev/mmcblk0p2 ro\0" \
19- "mmcrootfstype=ext3 rootwait\0" \
20+ "mmcrootfstype=ext4 rootwait\0" \
21 "mmcargs=setenv bootargs console=${console} " \
22 "vram=${vram} " \
23 "root=${mmcroot} " \
24--
251.7.2.5
26
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index ebcb3530..74597f62 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -2,7 +2,9 @@ require u-boot.inc
2 2
3# No patches for other machines yet 3# No patches for other machines yet
4COMPATIBLE_MACHINE = "(ti33x)" 4COMPATIBLE_MACHINE = "(ti33x)"
5
5DEFAULT_PREFERENCE_ti33x = "99" 6DEFAULT_PREFERENCE_ti33x = "99"
7
6PV = "2011.09+git" 8PV = "2011.09+git"
7PR = "r25" 9PR = "r25"
8 10
diff --git a/recipes-bsp/u-boot/u-boot_2011.12.bb b/recipes-bsp/u-boot/u-boot_2011.12.bb
new file mode 100644
index 00000000..5a19066f
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_2011.12.bb
@@ -0,0 +1,27 @@
1require u-boot.inc
2
3# SPL build
4UBOOT_BINARY = "u-boot.img"
5UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
6UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
7
8PV = "2011.12"
9PR = "r0"
10
11# No patches for other machines yet
12COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)"
13
14SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \
15 file://2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch \
16 file://2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch \
17 file://2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch \
18 file://2011.12/0004-omap4-common-mount-root-RO.patch \
19 file://2011.12/0005-omap4-common-use-ext4-by-default.patch \
20 "
21
22# v2011.12 tag
23SRCREV = "cba9a894fdb1cb49b60fcd1d1d6919cbd7995dd5"
24
25LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
26
27S = "${WORKDIR}/git"
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index 022d7fca..5abb6f5e 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -1,35 +1,12 @@
1require u-boot.inc 1require u-boot.inc
2PR ="r67" 2PR ="r67"
3 3
4DEFAULT_PREFERENCE = "-1"
4DEFAULT_PREFERENCE_ti814x = "-1" 5DEFAULT_PREFERENCE_ti814x = "-1"
5DEFAULT_PREFERENCE_ti816x = "-1" 6DEFAULT_PREFERENCE_ti816x = "-1"
6 7
7FILESPATHPKG =. "u-boot-git:" 8FILESPATHPKG =. "u-boot-git:"
8 9
9SRC_URI_beagleboard = "git://www.denx.de/git/u-boot.git;protocol=git \
10 file://0001-OMAP3-Beagle-Pin-Mux-initialization-glitch-fix.patch \
11 file://0002-OMAP-Remove-omapfb.debug-y-from-Beagle-and-Overo-env.patch \
12 file://0003-omap3_beagle-enable-the-use-of-a-plain-text-file-nam.patch \
13 file://0004-OMAP3-BeagleBoard-Enable-pullups-on-i2c2.patch \
14 file://0005-ARMV7-OMAP3-BeagleBoard-add-xM-rev-B-to-ID-table.patch \
15 file://0006-OMAP3-BeagleBoard-add-more-expansionboard-IDs.patch \
16 file://0007-OMAP3-Add-DSS-driver-for-OMAP3.patch \
17 file://0008-BeagleBoard-Added-userbutton-command.patch \
18 file://0009-OMAP3-beagle-pass-expansionboard-name-in-bootargs.patch \
19 file://0010-Enable-DSS-driver-for-Beagle.patch \
20 file://0011-Add-led-command.patch \
21 file://0012-BeagleBoard-Added-LED-driver.patch \
22 file://0013-OMAP3-BeagleBoard-updated-default-configuration.patch \
23 file://0014-Corrected-LED-name-match-finding-avoiding-extraneous.patch \
24 file://0015-omap3_beagle-Switch-default-console-from-ttyS2-to-tt.patch \
25 file://0016-BeagleBoard-Load-kernel-via-MMC-ext2-not-fat.patch \
26 file://fw_env.config \
27 "
28
29SRCREV_pn-${PN}_beagleboard = "c7977858dcf1f656cbe91ea0dc3cb9139c6a8cc8"
30PV_pn-${PN}_beagleboard = "2011.02+${PR}+gitr${SRCREV}"
31LIC_FILES_CHKSUM_pn-${PN}_beagleboard = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
32
33# ~ TI PSP v2009.11_OMAPPSP_03.00.01.06 (+ couple of commits) 10# ~ TI PSP v2009.11_OMAPPSP_03.00.01.06 (+ couple of commits)
34SRC_URI_omap3evm = "git://arago-project.org/git/projects/u-boot-omap3.git;protocol=git \ 11SRC_URI_omap3evm = "git://arago-project.org/git/projects/u-boot-omap3.git;protocol=git \
35 file://0001-omap3evm-Change-default-console-serial-port-from.patch \ 12 file://0001-omap3evm-Change-default-console-serial-port-from.patch \