summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot/0001-armv7-Unaligned-access-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot/0001-armv7-Unaligned-access-fix.patch')
-rw-r--r--recipes-bsp/u-boot/u-boot/0001-armv7-Unaligned-access-fix.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0001-armv7-Unaligned-access-fix.patch b/recipes-bsp/u-boot/u-boot/0001-armv7-Unaligned-access-fix.patch
new file mode 100644
index 00000000..35307ac0
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/0001-armv7-Unaligned-access-fix.patch
@@ -0,0 +1,30 @@
1From 40f1e7db785f477a2aa145a3b47bd498c48ad52d Mon Sep 17 00:00:00 2001
2From: Steve Kipisz <s-kipisz2@ti.com>
3Date: Fri, 14 Jun 2013 05:16:52 -0500
4Subject: [PATCH] armv7:Unaligned access fix
5
6This fixes an unaligned access data abort introduced when using gcc 4.7
7or higher. The Linaro toolchain uses gcc 4.7.3. This is documented in u-boot
8doc/README.arm-unaligned-accesses.
9
10Signed-off-by: Steve Kipisz <s-kipisz2@ti.com>
11---
12 arch/arm/cpu/armv7/config.mk | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/arch/arm/cpu/armv7/config.mk b/arch/arm/cpu/armv7/config.mk
16index 9c3e2f3..9736da8 100644
17--- a/arch/arm/cpu/armv7/config.mk
18+++ b/arch/arm/cpu/armv7/config.mk
19@@ -20,7 +20,7 @@
20 # Foundation, Inc., 59 Temple Place, Suite 330, Boston,
21 # MA 02111-1307 USA
22 #
23-PLATFORM_RELFLAGS += -fno-common -ffixed-r8 -msoft-float
24+PLATFORM_RELFLAGS += -fno-common -ffixed-r8 -msoft-float -mno-unaligned-access
25
26 # If armv7-a is not supported by GCC fall-back to armv5, which is
27 # supported by more tool-chains
28--
291.7.9.5
30