summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/transport-rtos/timesync-rtos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/transport-rtos/timesync-rtos_git.bb')
-rw-r--r--recipes-bsp/transport-rtos/timesync-rtos_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/transport-rtos/timesync-rtos_git.bb b/recipes-bsp/transport-rtos/timesync-rtos_git.bb
new file mode 100644
index 00000000..556c1288
--- /dev/null
+++ b/recipes-bsp/transport-rtos/timesync-rtos_git.bb
@@ -0,0 +1,31 @@
1SUMMARY = "RTOS driver for timesync driver"
2
3inherit ti-pdk
4require recipes-bsp/transport-rtos/transport.inc
5
6PR = "${INC_PR}.0"
7
8LIC_FILES_CHKSUM = "file://timeSync_ver.h;beginline=23;endline=45;md5=4bd873035e47065aaa811e53622992e9"
9
10COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g"
11
12DEPENDS_append = " ti-ndk \
13 osal-rtos \
14 pruss-lld-rtos \
15 icss-emac-lld-rtos \
16 nimu-icss-rtos \
17 edma3-lld-rtos \
18"
19
20TI_PDK_COMP = "ti.transport.timeSync"
21
22# Build with make instead of XDC
23TI_PDK_XDCMAKE = "0"
24
25export PDK_TIMESYNC_ROOT_PATH ="${WORKDIR}/build"
26export DEST_ROOT="${S}"
27
28export NDK_INSTALL_PATH = "${NDK_INSTALL_DIR}"
29export EDMA3LLD_BIOS6_INSTALLDIR = "${EDMA3_LLD_INSTALL_DIR}"
30
31XDCPATH_append = ";${NDK_INSTALL_DIR}/packages"