diff options
Diffstat (limited to 'recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb')
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb new file mode 100644 index 00000000..4294c6b5 --- /dev/null +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | DESCRIPTION = "TI SCI firmware" | ||
2 | |||
3 | LICENSE = "TI-TFL" | ||
4 | LIC_FILES_CHKSUM = "file://LICENCE.ti-keystone;md5=3a86335d32864b0bef996bee26cc0f2c" | ||
5 | |||
6 | PV = "0.1.0.70" | ||
7 | PR = "r0" | ||
8 | |||
9 | CLEANBROKEN = "1" | ||
10 | |||
11 | COMPATIBLE_MACHINE = "k2g-evm" | ||
12 | |||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
14 | |||
15 | SRCREV = "a5b1c3d043fef5869eaa937276976c0e3e23b966" | ||
16 | BRANCH ?= "master" | ||
17 | |||
18 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | TARGET = "ti-sci-firmware-k2g.bin" | ||
22 | |||
23 | do_install() { | ||
24 | install -d ${D}/boot | ||
25 | install -m 0644 ${S}/ti-keystone/${TARGET} ${D}/boot/${TARGET} | ||
26 | } | ||
27 | |||
28 | FILES_${PN} = "/boot" | ||
29 | |||
30 | inherit deploy | ||
31 | |||
32 | do_deploy () { | ||
33 | install -d ${DEPLOYDIR} | ||
34 | install -m 0644 ${S}/ti-keystone/${TARGET} ${DEPLOYDIR}/${TARGET} | ||
35 | } | ||
36 | |||
37 | addtask deploy before do_build after do_compile | ||