summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb')
-rw-r--r--recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
new file mode 100644
index 00000000..2812fa2c
--- /dev/null
+++ b/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Video Decoding Firmware Packaging recipe"
2LICENSE = "TI-TFL"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=84ca7278930db001870686ad997d6bb1"
4
5BRANCH = "master"
6SRCREV = "0acbf1d0a7c7eaca0ef14c1a30ce313ea82147e5"
7
8SRC_URI = "git://git.ti.com/jacinto7_multimedia/ti-img-encode-decode.git;protocol=git;branch=${BRANCH}"
9
10S = "${WORKDIR}/git"
11
12PV = "1.0-git${SRCPV}"
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15VXD_FW_DIR = "${S}/decoder/firmware/"
16
17# make sure that lib/firmware, and all its contents are part of the package
18FILES_${PN} += "${base_libdir}/firmware"
19
20do_install() {
21 install -d ${D}${base_libdir}/firmware
22 install -m 0755 ${VXD_FW_DIR}/pvdec_full_bin.fw ${D}${base_libdir}/firmware
23}
24
25# This is used to prevent the build system to strip the executables
26INHIBIT_PACKAGE_STRIP = "1"
27# This is used to prevent the build system to split the debug info in a separate file
28INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
29# As it likely to be a different arch from the Yocto build, disable checking by adding "arch" to INSANE_SKIP
30INSANE_SKIP_${PN} += "arch"
31
32# we don't want to configure and build the source code
33do_compile[noexec] = "1"
34do_configure[noexec] = "1"