summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb')
-rw-r--r--recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
new file mode 100644
index 00000000..cccda6bb
--- /dev/null
+++ b/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Video Decoding Firmware"
2LICENSE = "TI-IMG"
3LIC_FILES_CHKSUM = "file://LICENSE.ti-img;md5=84ca7278930db001870686ad997d6bb1"
4
5require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
6
7PV = "${IMG_DEC_FW_VERSION}"
8PR = "${INC_PR}.0"
9
10CLEANBROKEN = "1"
11
12COMPATIBLE_MACHINE = "j7"
13
14PACKAGE_ARCH = "${MACHINE_ARCH}"
15
16S = "${WORKDIR}/git"
17TARGET = "pvdec_full_bin.fw"
18
19do_install() {
20 install -d ${D}${base_libdir}/firmware/ti-img
21 install -m 0644 ${S}/ti-img/${TARGET} ${D}${base_libdir}/firmware/ti-img/${TARGET}
22}
23
24FILES_${PN} = "${base_libdir}/firmware"