summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/sa-lld
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/sa-lld')
-rw-r--r--recipes-bsp/sa-lld/sa-lld-test_git.bb2
-rw-r--r--recipes-bsp/sa-lld/sa-lld.inc18
-rw-r--r--recipes-bsp/sa-lld/sa-lld_git.bb2
3 files changed, 17 insertions, 5 deletions
diff --git a/recipes-bsp/sa-lld/sa-lld-test_git.bb b/recipes-bsp/sa-lld/sa-lld-test_git.bb
index 7cb0ac7a..4f74ab67 100644
--- a/recipes-bsp/sa-lld/sa-lld-test_git.bb
+++ b/recipes-bsp/sa-lld/sa-lld-test_git.bb
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip cppi-lld qmss-lld pa-lld sa-lld"
4 4
5include sa-lld.inc 5include sa-lld.inc
6 6
7PR = "${INC_PR}.0"
8
7DEVICELIST = "k2h k2k k2l k2e" 9DEVICELIST = "k2h k2k k2l k2e"
8 10
9CHOICELIST = "no yes" 11CHOICELIST = "no yes"
diff --git a/recipes-bsp/sa-lld/sa-lld.inc b/recipes-bsp/sa-lld/sa-lld.inc
index 80662796..47584b6e 100644
--- a/recipes-bsp/sa-lld/sa-lld.inc
+++ b/recipes-bsp/sa-lld/sa-lld.inc
@@ -3,11 +3,19 @@ COMPATIBLE_MACHINE = "keystone"
3 3
4LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/sa/COPYING.txt;md5=4709d353574a9569e129ebdf20e732dd" 4LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/sa/COPYING.txt;md5=4709d353574a9569e129ebdf20e732dd"
5 5
6BRANCH = "master" 6SA_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/sa-lld.git"
7SRC_URI = "git://git.ti.com/keystone-rtos/sa-lld.git;destsuffix=git/ti/drv/sa;protocol=git;branch=${BRANCH}" 7SA_LLD_GIT_PROTOCOL = "git"
8SA_LLD_GIT_BRANCH = "master"
9SA_LLD_GIT_DESTSUFFIX = "git/ti/drv/sa"
10
8# Following commit DEV.SA_LLD.03.00.00.11A 11# Following commit DEV.SA_LLD.03.00.00.11A
9SRCREV = "bf5b097e868b20d23d386abc34a1902903d7d9ea" 12SA_LLD_SRCREV = "bf5b097e868b20d23d386abc34a1902903d7d9ea"
13
14BRANCH = "${SA_LLD_GIT_BRANCH}"
15SRC_URI = "${SA_LLD_GIT_URI};destsuffix=${SA_LLD_GIT_DESTSUFFIX};protocol=${SA_LLD_GIT_PROTOCOL};branch=${BRANCH}"
16SRCREV = "${SA_LLD_SRCREV}"
17
10PV = "03.00.00.11" 18PV = "03.00.00.11"
19INC_PR = "r1"
11 20
12BASEDIR = "${WORKDIR}/git" 21S = "${WORKDIR}/${SA_LLD_GIT_DESTSUFFIX}"
13S = "${BASEDIR}/ti/drv/sa"
diff --git a/recipes-bsp/sa-lld/sa-lld_git.bb b/recipes-bsp/sa-lld/sa-lld_git.bb
index 3df2c6cb..1cab6db9 100644
--- a/recipes-bsp/sa-lld/sa-lld_git.bb
+++ b/recipes-bsp/sa-lld/sa-lld_git.bb
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip"
4 4
5include sa-lld.inc 5include sa-lld.inc
6 6
7PR = "${INC_PR}.0"
8
7do_compile () { 9do_compile () {
8# Now build the lld in the updated directory 10# Now build the lld in the updated directory
9 make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} 11 make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR}