diff options
Diffstat (limited to 'recipes-bsp/qmss-lld/qmss-lld_git.bb')
-rwxr-xr-x | recipes-bsp/qmss-lld/qmss-lld_git.bb | 16 |
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-bsp/qmss-lld/qmss-lld_git.bb b/recipes-bsp/qmss-lld/qmss-lld_git.bb index 9d2f547f..38b07621 100755 --- a/recipes-bsp/qmss-lld/qmss-lld_git.bb +++ b/recipes-bsp/qmss-lld/qmss-lld_git.bb | |||
@@ -5,6 +5,14 @@ DEPENDS="common-csl-ip rm-lld" | |||
5 | 5 | ||
6 | include qmss-lld.inc | 6 | include qmss-lld.inc |
7 | 7 | ||
8 | |||
9 | SRC_URI += "file://init_qmss.sh" | ||
10 | |||
11 | inherit update-rc.d | ||
12 | |||
13 | INITSCRIPT_NAME = "init_qmss.sh" | ||
14 | INITSCRIPT_PARAMS = "defaults 10" | ||
15 | |||
8 | do_compile () { | 16 | do_compile () { |
9 | # Now build the lld | 17 | # Now build the lld |
10 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} | 18 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} |
@@ -17,4 +25,12 @@ do_compile () { | |||
17 | 25 | ||
18 | do_install () { | 26 | do_install () { |
19 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | 27 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} |
28 | |||
29 | # Set the generic device library symbolic link to default k2h | ||
30 | cd ${D}${libdir} | ||
31 | ln -sf libqmss_k2h.so.1.0.0 libqmss_device.so.1 | ||
32 | ln -sf libqmss_device.so.1 libqmss_device.so | ||
33 | # Copy init scripts | ||
34 | install -d ${D}${sysconfdir}/init.d/ | ||
35 | install -c -m 755 ${WORKDIR}/init_qmss.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
20 | } | 36 | } |