summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/qmss-lld/qmss-lld_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/qmss-lld/qmss-lld_git.bb')
-rw-r--r--recipes-bsp/qmss-lld/qmss-lld_git.bb23
1 files changed, 9 insertions, 14 deletions
diff --git a/recipes-bsp/qmss-lld/qmss-lld_git.bb b/recipes-bsp/qmss-lld/qmss-lld_git.bb
index 83c9a7e3..813929ec 100644
--- a/recipes-bsp/qmss-lld/qmss-lld_git.bb
+++ b/recipes-bsp/qmss-lld/qmss-lld_git.bb
@@ -1,18 +1,10 @@
1DESCRIPTION = "TI QMSS low level driver library" 1DESCRIPTION = "TI QMSS low level driver library"
2COMPATIBLE_MACHINE = "keystone"
3 2
4DEPENDS="common-csl-ip rm-lld" 3DEPENDS="common-csl-ip rm-lld"
5 4
6include qmss-lld.inc 5include qmss-lld.inc
7 6
8PR = "${INC_PR}.0" 7PR = "${INC_PR}.1"
9
10SRC_URI += "file://init_qmss.sh"
11
12inherit update-rc.d
13
14INITSCRIPT_NAME = "init_qmss.sh"
15INITSCRIPT_PARAMS = "defaults 10"
16 8
17do_compile () { 9do_compile () {
18# Now build the lld 10# Now build the lld
@@ -27,11 +19,14 @@ do_compile () {
27do_install () { 19do_install () {
28 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} 20 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
29 21
30# Set the generic device library symbolic link to default k2h 22 # Set the generic device library symbolic link to default k2h
31 cd ${D}${libdir} 23 cd ${D}${libdir}
32 ln -sf libqmss_k2h.so.1.0.0 libqmss_device.so.1 24
25 # Link only the first device in the list
26 for device in ${DEVICELIST}
27 do
28 ln -sf libqmss_${device}.so.1.0.0 libqmss_device.so.1
29 break
30 done
33 ln -sf libqmss_device.so.1 libqmss_device.so 31 ln -sf libqmss_device.so.1 libqmss_device.so
34# Copy init scripts
35 install -d ${D}${sysconfdir}/init.d/
36 install -c -m 755 ${WORKDIR}/init_qmss.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
37} 32}