summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pruprp-fw/pruprp-fw_2.16.24.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/pruprp-fw/pruprp-fw_2.16.24.bb')
-rw-r--r--recipes-bsp/pruprp-fw/pruprp-fw_2.16.24.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-bsp/pruprp-fw/pruprp-fw_2.16.24.bb b/recipes-bsp/pruprp-fw/pruprp-fw_2.16.24.bb
new file mode 100644
index 00000000..56d8a576
--- /dev/null
+++ b/recipes-bsp/pruprp-fw/pruprp-fw_2.16.24.bb
@@ -0,0 +1,38 @@
1SUMMARY = "PRU PRP firmware for AM335x/AM437x/AM57xx"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5
6PE = "1"
7PR = "r0"
8
9CLEANBROKEN = "1"
10
11COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15SRCREV = "48e2c46ff62d796345b6587be58f88f0e608addc"
16BRANCH ?= "ti-linux-firmware"
17
18SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
19
20S = "${WORKDIR}/git"
21
22TARGET = ""
23TARGET_ti33x = "am335x-pru0-pruprp-fw.elf am335x-pru1-pruprp-fw.elf"
24TARGET_ti43x = "am437x-pru0-pruprp-fw.elf am437x-pru1-pruprp-fw.elf"
25TARGET_am57xx-evm = "am57xx-pru0-pruprp-fw.elf am57xx-pru1-pruprp-fw.elf"
26TARGET_am57xx-hs-evm = "am57xx-pru0-pruprp-fw.elf am57xx-pru1-pruprp-fw.elf"
27
28
29do_install() {
30 install -d ${D}${base_libdir}/firmware/ti-pruss
31 for f in ${TARGET}; do
32 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
33 done
34}
35
36FILES_${PN} = "${base_libdir}/firmware"
37
38INSANE_SKIP_${PN} = "arch"