summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pruhsr-fw/pruhsr-fw_2.15.23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/pruhsr-fw/pruhsr-fw_2.15.23.bb')
-rw-r--r--recipes-bsp/pruhsr-fw/pruhsr-fw_2.15.23.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-bsp/pruhsr-fw/pruhsr-fw_2.15.23.bb b/recipes-bsp/pruhsr-fw/pruhsr-fw_2.15.23.bb
new file mode 100644
index 00000000..1434363f
--- /dev/null
+++ b/recipes-bsp/pruhsr-fw/pruhsr-fw_2.15.23.bb
@@ -0,0 +1,37 @@
1SUMMARY = "PRU HSR firmware for AM335x/AM437x/AM57xx"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5
6PE = "1"
7PR = "r0"
8
9CLEANBROKEN = "1"
10
11COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15SRCREV = "7ba9722b74608ad4472790972917e1205eb3c049"
16BRANCH ?= "ti-linux-firmware"
17
18SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
19
20S = "${WORKDIR}/git"
21
22TARGET = ""
23TARGET_ti33x = "am335x-pru0-pruhsr-fw.elf am335x-pru1-pruhsr-fw.elf"
24TARGET_ti43x = "am437x-pru0-pruhsr-fw.elf am437x-pru1-pruhsr-fw.elf"
25TARGET_am57xx-evm = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
26TARGET_am57xx-hs-evm = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
27
28do_install() {
29 install -d ${D}${base_libdir}/firmware/ti-pruss
30 for f in ${TARGET}; do
31 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
32 done
33}
34
35FILES_${PN} = "${base_libdir}/firmware"
36
37INSANE_SKIP_${PN} = "arch"