summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pru/pru-swuart-fw_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/pru/pru-swuart-fw_git.bb')
-rw-r--r--recipes-bsp/pru/pru-swuart-fw_git.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/recipes-bsp/pru/pru-swuart-fw_git.bb b/recipes-bsp/pru/pru-swuart-fw_git.bb
deleted file mode 100644
index f0d9e80d..00000000
--- a/recipes-bsp/pru/pru-swuart-fw_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "Programmable Real-time Unit Software UART Firmware"
2LICENSE = "BSD-3-Clause"
3
4LIC_FILES_CHKSUM = "file://COPYING.txt;beginline=1;endline=31;md5=94b6a199da1caf777f6756cb70aca4a7"
5
6require recipes-ti/includes/ti-paths.inc
7
8COMPATIBLE_MACHINE = "ti33x"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11
12inherit ti-pdk-fetch
13
14TI_PDK_COMP = "ti.drv.uart"
15
16PE = "1"
17
18SRC_URI:append = " \
19 file://0001-icss_uart-add-Makefile-for-building-firmware.patch \
20 file://0001-icss_uart-remove-dependency-on-PDK-CSL.patch \
21"
22
23DEPENDS = "ti-cgt-pru-native pru-icss"
24
25
26export PRU_CGT = "${TI_CGT_PRU_INSTALL_DIR}"
27export PRU_SSP = "${STAGING_DIR_TARGET}/usr"
28
29do_compile() {
30 oe_runmake -C firmware/icss_uart/src
31}
32
33do_install() {
34 install -d ${D}/lib/firmware/ti-pruss
35 install -m 0644 ${S}/firmware/icss_uart/src/gen/src.out ${D}/lib/firmware/ti-pruss/pru_swuart-fw.elf
36}
37
38FILES:${PN} = "/lib/firmware"
39
40INSANE_SKIP:${PN} = "arch"