diff options
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r-- | recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb | 68 |
1 files changed, 68 insertions, 0 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb new file mode 100644 index 00000000..6a07d4f8 --- /dev/null +++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb | |||
@@ -0,0 +1,68 @@ | |||
1 | DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://GPL-COPYING;md5=60422928ba677faaa13d6ab5f5baaa1e" | ||
4 | |||
5 | TI_BIN_UNPK_CMDS="Y: qY:workdir:Y" | ||
6 | require ../../recipes-ti/includes/ti-eula-unpack.inc | ||
7 | |||
8 | SGXPV = "5_01_01_02" | ||
9 | IMGPV = "1.10.2359475" | ||
10 | |||
11 | inherit module | ||
12 | |||
13 | MACHINE_KERNEL_PR_append = "a" | ||
14 | PR = "${MACHINE_KERNEL_PR}" | ||
15 | |||
16 | BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin" | ||
17 | MD5SUM_HARDFP = "94bcb31ea7eb50df1dfa4037055b638e" | ||
18 | SHA256SUM_HARDFP = "54641222cdb49b03f996cbd6412de227198d9e084f5647d706bbf4217e8cdb07" | ||
19 | |||
20 | # For now we only have hardfp version | ||
21 | python __anonymous() { | ||
22 | tunes = bb.data.getVar("TUNE_FEATURES", d, 1) | ||
23 | if not tunes: | ||
24 | return | ||
25 | pkgn = bb.data.getVar("PN", d, 1) | ||
26 | pkgv = bb.data.getVar("PV", d, 1) | ||
27 | if "callconvention-hard" not in tunes: | ||
28 | bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) | ||
29 | raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) | ||
30 | } | ||
31 | |||
32 | BINFILE := "${BINFILE_HARDFP}" | ||
33 | |||
34 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/gfxsdk/${SGXPV}/exports/${BINFILE}" | ||
35 | |||
36 | |||
37 | SRC_URI[md5sum] := "${MD5SUM_HARDFP}" | ||
38 | SRC_URI[sha256sum] := "${SHA256SUM_HARDFP}" | ||
39 | |||
40 | TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}" | ||
41 | S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM" | ||
42 | |||
43 | PVRBUILD = "release" | ||
44 | export KERNELDIR = "${STAGING_KERNEL_DIR}" | ||
45 | |||
46 | INHIBIT_PACKAGE_STRIP = "1" | ||
47 | |||
48 | TI_PLATFORM_omap3 = "omap3630" | ||
49 | TI_PLATFORM_ti814x = "ti81xx" | ||
50 | TI_PLATFORM_ti816x = "ti81xx" | ||
51 | TI_PLATFORM_ti33x = "ti335x" | ||
52 | TI_PLATFORM_ti43x = "ti43xx" | ||
53 | |||
54 | MODULESLOCATION_omap3 = "dc_omapfb3_linux" | ||
55 | MODULESLOCATION_ti814x = "dc_ti81xx_linux" | ||
56 | MODULESLOCATION_ti816x = "dc_ti81xx_linux" | ||
57 | MODULESLOCATION_ti33x = "dc_ti335x_linux" | ||
58 | MODULESLOCATION_ti43x = "dc_ti43xx_linux" | ||
59 | |||
60 | MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}" | ||
61 | |||
62 | do_install() { | ||
63 | mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | ||
64 | cp ${S}/pvrsrvkm.ko \ | ||
65 | ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \ | ||
66 | ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \ | ||
67 | ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | ||
68 | } | ||