summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb
deleted file mode 100644
index cf042fcd..00000000
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb
+++ /dev/null
@@ -1,58 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://GPL-COPYING;md5=60422928ba677faaa13d6ab5f5baaa1e"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "5_01_01_02"
9IMGPV = "1.10.2359475"
10
11inherit module
12
13MACHINE_KERNEL_PR_append = "b"
14PR = "${MACHINE_KERNEL_PR}"
15
16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin"
17MD5SUM_HARDFP = "94bcb31ea7eb50df1dfa4037055b638e"
18SHA256SUM_HARDFP = "54641222cdb49b03f996cbd6412de227198d9e084f5647d706bbf4217e8cdb07"
19
20# For now we only have hardfp version
21python __anonymous() {
22 tunes = bb.data.getVar("TUNE_FEATURES", d, 1)
23 if not tunes:
24 return
25 pkgn = bb.data.getVar("PN", d, 1)
26 pkgv = bb.data.getVar("PV", d, 1)
27 if "callconvention-hard" not in tunes:
28 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
29 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
30}
31
32BINFILE := "${BINFILE_HARDFP}"
33
34SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/gfxsdk/${SGXPV}/exports/${BINFILE}"
35
36
37SRC_URI[md5sum] := "${MD5SUM_HARDFP}"
38SRC_URI[sha256sum] := "${SHA256SUM_HARDFP}"
39
40TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
41S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
42
43PVRBUILD = "release"
44export KERNELDIR = "${STAGING_KERNEL_DIR}"
45
46INHIBIT_PACKAGE_STRIP = "1"
47
48TI_PLATFORM_omap3 = "omap3630"
49TI_PLATFORM_ti814x = "ti81xx"
50TI_PLATFORM_ti816x = "ti81xx"
51TI_PLATFORM_ti33x = "ti335x"
52TI_PLATFORM_ti43x = "ti43xx"
53
54MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
55
56do_install() {
57 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
58}