summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb62
1 files changed, 0 insertions, 62 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb
deleted file mode 100644
index 1ac60da7..00000000
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb
+++ /dev/null
@@ -1,62 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://GPL-COPYING;md5=60422928ba677faaa13d6ab5f5baaa1e"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "5_01_01_01"
9IMGPV = "1.10.2359475"
10
11inherit module
12
13MACHINE_KERNEL_PR_append = "d"
14PR = "${MACHINE_KERNEL_PR}"
15
16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin"
17MD5SUM_HARDFP = "94acdbd20152c905939c2448d5e80a72"
18SHA256SUM_HARDFP = "7f647bf45a5ce8ba9aaa28c4afe85fced4275f9a4567a1886d4460b76c9051ae"
19
20# For now we only have hardfp version
21python __anonymous() {
22 tunes = bb.data.getVar("TUNE_FEATURES", d, 1)
23 if not tunes:
24 return
25 pkgn = bb.data.getVar("PN", d, 1)
26 pkgv = bb.data.getVar("PV", d, 1)
27 if "callconvention-hard" not in tunes:
28 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
29 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
30}
31
32BINFILE := "${BINFILE_HARDFP}"
33
34SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/gfxsdk/${SGXPV}/exports/${BINFILE}"
35
36SRC_URI += "file://0001-PoC-GFX-SDK-Make-5_01_01_01-work-against-3.14-LTS.patch;striplevel=2 \
37 file://0002-SGX-linux-use-platform-data-to-provide-reset-info.patch;striplevel=2 \
38 file://0003-SGX-displayclass-am335x-am437x-fix-mutex-deadlock-wa.patch;striplevel=2 \
39 file://0004-SGX-linux-make-it-building-against-ti-linux-3.14.y.patch;striplevel=2"
40
41SRC_URI[md5sum] := "${MD5SUM_HARDFP}"
42SRC_URI[sha256sum] := "${SHA256SUM_HARDFP}"
43
44TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
45S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
46
47PVRBUILD = "release"
48export KERNELDIR = "${STAGING_KERNEL_DIR}"
49
50INHIBIT_PACKAGE_STRIP = "1"
51
52TI_PLATFORM_omap3 = "omap3630"
53TI_PLATFORM_ti814x = "ti81xx"
54TI_PLATFORM_ti816x = "ti81xx"
55TI_PLATFORM_ti33x = "ti335x"
56TI_PLATFORM_ti43x = "ti43xx"
57
58MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
59
60do_install() {
61 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
62}