summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.02.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.02.bb')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.02.bb54
1 files changed, 0 insertions, 54 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.02.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.02.bb
deleted file mode 100644
index d5737cdf..00000000
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.02.bb
+++ /dev/null
@@ -1,54 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ea5743acf520dd81ca172e69f818a3d4"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "4_08_00_02"
9IMGPV = "1.9.2188537"
10BINFILE = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin"
11
12inherit module
13
14MACHINE_KERNEL_PR_append = "a"
15PR = "${MACHINE_KERNEL_PR}"
16
17SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE}"
18
19SRC_URI[md5sum] = "0efa3a38266e6f41f8cc4fad0187f0d6"
20SRC_URI[sha256sum] = "c732044b515a598e1fab661b7463aa9c53d4fa37f4980dfa85cd02b7468d0cd9"
21
22TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
23S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
24
25PVRBUILD = "release"
26export KERNELDIR = "${STAGING_KERNEL_DIR}"
27
28INHIBIT_PACKAGE_STRIP = "1"
29
30TI_PLATFORM_omap3 = "omap3630"
31TI_PLATFORM_ti814x = "ti81xx"
32TI_PLATFORM_ti816x = "ti81xx"
33TI_PLATFORM_ti33x = "ti335x"
34
35MODULESLOCATION_omap3 = "dc_omapfb3_linux"
36MODULESLOCATION_ti814x = "dc_ti81xx_linux"
37MODULESLOCATION_ti816x = "dc_ti81xx_linux"
38MODULESLOCATION_ti33x = "dc_ti335x_linux"
39
40export SUPPORT_XORG ?= "${@base_contains('DISTRO_FEATURES', 'x11', '1', '0', d)}"
41
42MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
43
44do_install() {
45 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
46 cp ${S}/pvrsrvkm.ko \
47 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
48 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
49 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
50
51 if [ "${SUPPORT_XORG}" = "1" ]; then
52 cp ${S}/services4/3rdparty/linux_drm/drm.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
53 fi
54}