summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb
deleted file mode 100644
index a54a643b..00000000
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=21228a42e27d1d104b31a83f7c9da935"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "4_05_00_03"
9BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
10
11inherit module
12
13MACHINE_KERNEL_PR_append = "c"
14PR = "${MACHINE_KERNEL_PR}"
15
16DEFAULT_PREFERENCE_omap3 = "99"
17
18SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
19 "
20SRC_URI[md5sum] = "0e651eaa92bb91760f0b40a17697a7dc"
21SRC_URI[sha256sum] = "bfe764a8959556195545d6fff76f63a489642f345c105bbbc309a3f243c2dd0e"
22TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
23S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
24
25PVRBUILD = "release"
26export KERNELDIR = "${STAGING_KERNEL_DIR}"
27
28INHIBIT_PACKAGE_STRIP = "1"
29
30TI_PLATFORM_omap3 = "omap3630"
31TI_PLATFORM_ti814x = "ti81xx"
32TI_PLATFORM_ti816x = "ti81xx"
33TI_PLATFORM_ti33x = "ti335x"
34
35MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM}"
36
37do_install() {
38 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
39}