summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb
new file mode 100644
index 00000000..6508f362
--- /dev/null
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=21228a42e27d1d104b31a83f7c9da935"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "4_03_00_02"
9IMGPV = "1.6.16.3977"
10BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
11
12inherit module
13
14MACHINE_KERNEL_PR_append = "i"
15
16SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
17 file://Compile-fixes-for-38-kernel.patch \
18 "
19SRC_URI[md5sum] = "ff8c1f2b8e4cb42f4ced6a613b081ada"
20SRC_URI[sha256sum] = "cdb0bd3964e107733d632aa8224e0537b05c1ffac34befc036423458c8d75255"
21
22S = "${WORKDIR}/Graphics_SDK_${SGXPV}/GFX_Linux_KM"
23
24PVRBUILD = "release"
25export KERNELDIR = "${STAGING_KERNEL_DIR}"
26
27PACKAGE_STRIP = "no"
28
29TI_PLATFORM_omap3 = "omap3630"
30TI_PLATFORM_ti816x = "ti81xx"
31
32MODULESLOCATION_omap3 = "dc_omap3430_linux"
33MODULESLOCATION_ti816x = "dc_ti81xx_linux"
34
35MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM}"
36
37do_install() {
38 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
39 cp ${S}/pvrsrvkm.ko \
40 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
41 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
42 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
43}