summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb')
-rw-r--r--recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb20
1 files changed, 5 insertions, 15 deletions
diff --git a/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb b/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb
index 51a24e7d..cbf15a37 100644
--- a/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb
+++ b/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb
@@ -1,6 +1,10 @@
1SUMMARY = "TI RTOS low lever driver for Peripheral Interconnect Express (PCIE)" 1SUMMARY = "TI RTOS low lever driver for Peripheral Interconnect Express (PCIE)"
2 2
3inherit ti-pdk 3inherit ti-pdk ti-pdk-fetch
4
5TI_PDK_COMP = "ti.drv.pcie"
6
7PE = "1"
4 8
5LICENSE = "BSD-3-Clause" 9LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://pcie.h;beginline=1;endline=34;md5=566a784d78790a716d641764d5d60b74" 10LIC_FILES_CHKSUM = "file://pcie.h;beginline=1;endline=34;md5=566a784d78790a716d641764d5d60b74"
@@ -8,25 +12,11 @@ LIC_FILES_CHKSUM = "file://pcie.h;beginline=1;endline=34;md5=566a784d78790a716d6
8COMPATIBLE_MACHINE = "omap-a15|keystone|c66x|k3" 12COMPATIBLE_MACHINE = "omap-a15|keystone|c66x|k3"
9PACKAGE_ARCH = "${MACHINE_ARCH}" 13PACKAGE_ARCH = "${MACHINE_ARCH}"
10 14
11PCIE_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pcie-lld.git"
12PCIE_LLD_GIT_PROTOCOL = "git"
13PCIE_LLD_GIT_BRANCH = "master"
14PCIE_LLD_GIT_DESTSUFFIX = "git/ti/drv/pcie"
15
16# Below commit ID corresponds to "DEV.PCIE_LLD.02.03.00.05"
17PCIE_LLD_SRCREV = "3cdbb5e4e4ccced496a4ca91b203965fafffc3e9"
18
19BRANCH = "${PCIE_LLD_GIT_BRANCH}"
20SRC_URI = "${PCIE_LLD_GIT_URI};destsuffix=${PCIE_LLD_GIT_DESTSUFFIX};protocol=${PCIE_LLD_GIT_PROTOCOL};branch=${BRANCH}"
21
22SRCREV = "${PCIE_LLD_SRCREV}"
23PV = "02.03.00.05"
24PR = "r0" 15PR = "r0"
25 16
26DEPENDS_append_k3 = " udma-lld-rtos \ 17DEPENDS_append_k3 = " udma-lld-rtos \
27" 18"
28 19
29S = "${WORKDIR}/${PCIE_LLD_GIT_DESTSUFFIX}"
30 20
31export PDK_PCIE_ROOT_PATH ="${WORKDIR}/build" 21export PDK_PCIE_ROOT_PATH ="${WORKDIR}/build"
32export DEST_ROOT="${S}" 22export DEST_ROOT="${S}"