summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb')
-rw-r--r--recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb b/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb
new file mode 100644
index 00000000..174cbfd0
--- /dev/null
+++ b/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb
@@ -0,0 +1,35 @@
1SUMMARY = "TI RTOS low lever driver for Peripheral Interconnect Express (PCIE)"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://pcie.h;beginline=1;endline=34;md5=c094db055596498ba803933936611eb2"
7
8COMPATIBLE_MACHINE = "omap-a15|keystone|c66x"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11PCIE_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pcie-lld.git"
12PCIE_LLD_GIT_PROTOCOL = "git"
13PCIE_LLD_GIT_BRANCH = "master"
14PCIE_LLD_GIT_DESTSUFFIX = "git/ti/drv/pcie"
15
16# Below commit ID corresponds to "DEV.PCIE_LLD.02.02.00.09"
17PCIE_LLD_SRCREV = "93f302f6f3dd3a83ac0dd0e24b3965f98f46eac7"
18
19BRANCH = "${PCIE_LLD_GIT_BRANCH}"
20SRC_URI = "${PCIE_LLD_GIT_URI};destsuffix=${PCIE_LLD_GIT_DESTSUFFIX};protocol=${PCIE_LLD_GIT_PROTOCOL};branch=${BRANCH}"
21
22SRCREV = "${PCIE_LLD_SRCREV}"
23PV = "02.02.00.09"
24PR = "r0"
25
26S = "${WORKDIR}/${PCIE_LLD_GIT_DESTSUFFIX}"
27
28export PDK_PCIE_ROOT_PATH ="${WORKDIR}/build"
29export DEST_ROOT="${S}"
30
31# Build with make instead of XDC
32TI_PDK_XDCMAKE = "0"
33
34# HTML doc link params
35PDK_COMP_LINK_TEXT = "PCIe LLD"