summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pa-lld/pa-lld_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/pa-lld/pa-lld_git.bb')
-rw-r--r--recipes-bsp/pa-lld/pa-lld_git.bb21
1 files changed, 7 insertions, 14 deletions
diff --git a/recipes-bsp/pa-lld/pa-lld_git.bb b/recipes-bsp/pa-lld/pa-lld_git.bb
index 0cb3bc50..501ee2d9 100644
--- a/recipes-bsp/pa-lld/pa-lld_git.bb
+++ b/recipes-bsp/pa-lld/pa-lld_git.bb
@@ -4,27 +4,20 @@ DEPENDS = "common-csl-ip rm-lld"
4 4
5include pa-lld.inc 5include pa-lld.inc
6 6
7PR = "${INC_PR}.0" 7PR = "${INC_PR}.1"
8
9SRC_URI += "file://init_pa.sh"
10
11inherit update-rc.d
12
13INITSCRIPT_NAME = "init_pa.sh"
14INITSCRIPT_PARAMS = "defaults 10"
15 8
16do_compile () { 9do_compile () {
17# Now build the lld in the updated directory 10# Now build the lld in the updated directory
18 make -f makefile_armv7 DEVICE=k2h clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} 11 for device in ${DEVICELIST}
19 make -f makefile_armv7 DEVICE=k2l lib PDK_INSTALL_PATH=${STAGING_INCDIR} 12 do
13 make -f makefile_armv7 DEVICE=$device lib PDK_INSTALL_PATH=${STAGING_INCDIR}
14 done
20} 15}
21 16
22do_install () { 17do_install () {
23 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} 18 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
19
24# Set the generic device library symbolic link 20# Set the generic device library symbolic link
25 ln -sf libpa.so.1.0.0 ${D}${libdir}/libpa_device.so.1 21 ln -sf ${LIBPA}.so.1.0.0 ${D}${libdir}/libpa_device.so.1
26 ln -sf libpa_device.so.1 ${D}${libdir}/libpa_device.so 22 ln -sf libpa_device.so.1 ${D}${libdir}/libpa_device.so
27# Copy init scripts
28 install -d ${D}${sysconfdir}/init.d/
29 install -c -m 755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
30} 23}