diff options
Diffstat (limited to 'recipes-bsp/osal')
-rw-r--r-- | recipes-bsp/osal/osal-rtos_git.bb | 18 | ||||
-rw-r--r-- | recipes-bsp/osal/osal.inc | 8 |
2 files changed, 22 insertions, 4 deletions
diff --git a/recipes-bsp/osal/osal-rtos_git.bb b/recipes-bsp/osal/osal-rtos_git.bb new file mode 100644 index 00000000..da421b61 --- /dev/null +++ b/recipes-bsp/osal/osal-rtos_git.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | inherit ti-pdk | ||
2 | require recipes-bsp/osal/osal.inc | ||
3 | |||
4 | PR = "${INC_PR}.0" | ||
5 | |||
6 | S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}" | ||
7 | |||
8 | DEPENDS_append_ti33x = " starterware-rtos" | ||
9 | DEPENDS_append_ti43x = " starterware-rtos" | ||
10 | |||
11 | # Build with make instead of XDC | ||
12 | TI_PDK_XDCMAKE = "0" | ||
13 | |||
14 | export PDK_OSAL_ROOT_PATH ="${WORKDIR}/build" | ||
15 | export DEST_ROOT="${S}" | ||
16 | |||
17 | # HTML doc link params | ||
18 | PDK_COMP_LINK_TEXT = "OSAL Library" | ||
diff --git a/recipes-bsp/osal/osal.inc b/recipes-bsp/osal/osal.inc index fa8cde8e..63ccca9b 100644 --- a/recipes-bsp/osal/osal.inc +++ b/recipes-bsp/osal/osal.inc | |||
@@ -1,7 +1,7 @@ | |||
1 | LICENSE = "BSD-3-Clause" | 1 | LICENSE = "BSD-3-Clause" |
2 | LIC_FILES_CHKSUM = "file://osal.h;beginline=1;endline=31;md5=ae7b9f0410f26c80dcf790ef3f622fad" | 2 | LIC_FILES_CHKSUM = "file://osal.h;beginline=1;endline=31;md5=ae7b9f0410f26c80dcf790ef3f622fad" |
3 | 3 | ||
4 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone" | 4 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1" |
5 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 5 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
6 | 6 | ||
7 | OSAL_GIT_URI = "git://git.ti.com/keystone-rtos/osal.git" | 7 | OSAL_GIT_URI = "git://git.ti.com/keystone-rtos/osal.git" |
@@ -9,12 +9,12 @@ OSAL_GIT_PROTOCOL = "git" | |||
9 | OSAL_GIT_BRANCH = "master" | 9 | OSAL_GIT_BRANCH = "master" |
10 | OSAL_GIT_DESTSUFFIX = "git/ti/osal" | 10 | OSAL_GIT_DESTSUFFIX = "git/ti/osal" |
11 | 11 | ||
12 | # Below commit ID corresponding to "DEV.OSAL.01.00.00.06E" | 12 | # Below commit ID corresponding to "DEV.OSAL.01.00.00.07" |
13 | OSAL_SRCREV = "072ab0f76fa272ace5b1756075475f848c14221a" | 13 | OSAL_SRCREV = "62ea536572d91a17321dfca287771a5b65e6e00d" |
14 | 14 | ||
15 | BRANCH = "${OSAL_GIT_BRANCH}" | 15 | BRANCH = "${OSAL_GIT_BRANCH}" |
16 | SRC_URI = "${OSAL_GIT_URI};destsuffix=${OSAL_GIT_DESTSUFFIX};protocol=${OSAL_GIT_PROTOCOL};branch=${BRANCH}" | 16 | SRC_URI = "${OSAL_GIT_URI};destsuffix=${OSAL_GIT_DESTSUFFIX};protocol=${OSAL_GIT_PROTOCOL};branch=${BRANCH}" |
17 | 17 | ||
18 | SRCREV = "${OSAL_SRCREV}" | 18 | SRCREV = "${OSAL_SRCREV}" |
19 | PV = "01.00.00.06E" | 19 | PV = "01.00.00.07" |
20 | INC_PR = "r0" | 20 | INC_PR = "r0" |