summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/mmap-lld/mmap-lld_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/mmap-lld/mmap-lld_git.bb')
-rwxr-xr-xrecipes-bsp/mmap-lld/mmap-lld_git.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-bsp/mmap-lld/mmap-lld_git.bb b/recipes-bsp/mmap-lld/mmap-lld_git.bb
new file mode 100755
index 00000000..3a56a620
--- /dev/null
+++ b/recipes-bsp/mmap-lld/mmap-lld_git.bb
@@ -0,0 +1,12 @@
1DESCRIPTION = "TI KEYSTONE mmap driver using Keystone MPAX Programming"
2include mmap-lld.inc
3
4DEPENDS="common-csl-ip"
5
6do_compile () {
7 make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR}
8}
9
10do_install () {
11 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
12}