summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/mcasp-lld/mcasp-lld-rtos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/mcasp-lld/mcasp-lld-rtos_git.bb')
-rw-r--r--recipes-bsp/mcasp-lld/mcasp-lld-rtos_git.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-bsp/mcasp-lld/mcasp-lld-rtos_git.bb b/recipes-bsp/mcasp-lld/mcasp-lld-rtos_git.bb
new file mode 100644
index 00000000..11b18c53
--- /dev/null
+++ b/recipes-bsp/mcasp-lld/mcasp-lld-rtos_git.bb
@@ -0,0 +1,45 @@
1SUMMARY = "TI RTOS low level driver for Multi channel Audio Serial port (McASP)"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://mcaspver.h;beginline=1;endline=47;md5=cc81a11c1566fe1cf19270744f504619"
7
8COMPATIBLE_MACHINE = "ti43x|omap-a15|k2g|ti33x|omapl1"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11MCASP_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/mcasp-lld.git"
12MCASP_LLD_GIT_PROTOCOL = "git"
13MCASP_LLD_GIT_BRANCH = "master"
14MCASP_LLD_GIT_DESTSUFFIX = "git/ti/drv/mcasp"
15
16# Below commit ID corresponds to "DEV.MCASP_LLD.01.01.00.06B"
17MCASP_LLD_SRCREV = "c64ca018d4482f6841e7f8fde3a7adf50f4d329f"
18
19BRANCH = "${MCASP_LLD_GIT_BRANCH}"
20SRC_URI = "${MCASP_LLD_GIT_URI};destsuffix=${MCASP_LLD_GIT_DESTSUFFIX};protocol=${MCASP_LLD_GIT_PROTOCOL};branch=${BRANCH}"
21
22SRCREV = "${MCASP_LLD_SRCREV}"
23PV = "01.01.00.06B"
24PR = "r0"
25
26S = "${WORKDIR}/${MCASP_LLD_GIT_DESTSUFFIX}"
27
28DEPENDS_append = " edma3-lld-rtos \
29 osal-rtos \
30"
31DEPENDS_append_ti43x = " starterware-rtos \
32"
33DEPENDS_append_ti33x = " starterware-rtos \
34"
35# Build with make instead of XDC
36TI_PDK_XDCMAKE = "0"
37
38export PDK_MCASP_ROOT_PATH ="${WORKDIR}/build"
39export DEST_ROOT="${S}"
40
41export EDMA3LLD_BIOS6_INSTALLDIR = "${EDMA3_LLD_INSTALL_DIR}"
42XDCPATH_append = ";${EDMA3_LLD_INSTALL_DIR}/packages"
43
44# HTML doc link params
45PDK_COMP_LINK_TEXT = "MCASP LLD"