diff options
Diffstat (limited to 'recipes-bsp/ipumm-fw')
-rw-r--r-- | recipes-bsp/ipumm-fw/ipumm-fw_3.00.08.01.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_3.00.08.01.bb b/recipes-bsp/ipumm-fw/ipumm-fw_3.00.08.01.bb new file mode 100644 index 00000000..2e43584f --- /dev/null +++ b/recipes-bsp/ipumm-fw/ipumm-fw_3.00.08.01.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | python __anonymous() { | ||
2 | features = bb.data.getVar("MACHINE_FEATURES", d, 1) | ||
3 | if not features: | ||
4 | return | ||
5 | if "mmip" not in features: | ||
6 | raise bb.parse.SkipPackage('ipumm-fw does not apply to systems without the "mmip" flag in MACHINE_FEATURES') | ||
7 | } | ||
8 | |||
9 | DESCRIPTION = "Firmware for IPU for supporting Accelerated MM decode and encode" | ||
10 | LICENSE = "TI-TSPA" | ||
11 | |||
12 | LIC_FILES_CHKSUM = "file://MMIP-${PV}-Manifest.doc;md5=caa45d993ac010abe2fd319f6613bc26" | ||
13 | |||
14 | COMPATIBLE_MACHINE = "dra7xx" | ||
15 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
16 | |||
17 | RDEPENDS_${PN} = "libdce" | ||
18 | |||
19 | SRC_URI = "http://arago-project.org/files/short-term/misc/ipumm-dra7xx-evm-${PV}.tar.gz;protocol=http" | ||
20 | |||
21 | SRC_URI[md5sum] = "e770dce63fdf218bb19ceb748d9812c0" | ||
22 | SRC_URI[sha256sum] = "044d49b77560660bdfc29894e669fe8f70dc467c66b4acb49b24722a0799baa1" | ||
23 | |||
24 | S = "${WORKDIR}/ipumm-dra7xx-evm-${PV}" | ||
25 | |||
26 | TARGET = "dra7-ipu2-fw.xem4" | ||
27 | |||
28 | do_install() { | ||
29 | mkdir -p ${D}${base_libdir}/firmware | ||
30 | cp ${S}/firmware/${TARGET} ${D}${base_libdir}/firmware/${TARGET} | ||
31 | } | ||
32 | |||
33 | FILES_${PN} += "${base_libdir}/firmware/${TARGET}" | ||