summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb')
-rw-r--r--recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb75
1 files changed, 0 insertions, 75 deletions
diff --git a/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb b/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
deleted file mode 100644
index 1e072272..00000000
--- a/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
+++ /dev/null
@@ -1,75 +0,0 @@
1SUMMARY = "Second stage bootloader for c66x"
2DESCRIPTION = "The Intermediate Bootloader (IBL) is a second stage \
3bootloader for the c66x family of embedded processors. This second \
4stage bootloader takes care of additional initializations, advisory \
5setups, and errata workarounds that are not present in the first stage boot."
6
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://src/ibl.h;beginline=1;endline=34;md5=ee7d7a3305d1e524955996d1c5e31cb9"
9
10require recipes-ti/includes/ti-paths.inc
11
12DEPENDS = " ti-cgt6x-7-native \
13 bison-native \
14 flex-native \
15"
16
17PACKAGE_ARCH = "${MACHINE_ARCH}"
18COMPATIBLE_MACHINE = "c66x"
19
20CLEANBROKEN = "1"
21
22IBL_BOOT_GIT_URI = "git://git.ti.com/keystone-rtos/ibl.git"
23IBL_BOOT_GIT_PROTOCOL = "git"
24IBL_BOOT_GIT_BRANCH = "master"
25IBL_BOOT_SRCREV = "ed3f0989d8cdc813b7ca1ed899c4d84b63de3a75"
26
27BRANCH = "${IBL_BOOT_GIT_BRANCH}"
28SRC_URI = "${IBL_BOOT_GIT_URI};protocol=${IBL_BOOT_GIT_PROTOCOL};branch=${BRANCH}"
29SRCREV = "${IBL_BOOT_SRCREV}"
30
31
32PR = "r2"
33
34S = "${WORKDIR}/git"
35
36PATH:prepend = "${TI_CGT6X_7_INSTALL_DIR}/bin:"
37
38IBLTARGETS = ""
39IBLTARGETS_c665x-evm = "evm_c6657_i2c"
40IBLTARGETS_c667x-evm = "evm_c6678_i2c"
41
42IBLENDIAN = ""
43IBLENDIAN_c665x-evm = "little"
44IBLENDIAN_c667x-evm = "little"
45
46export C6X_BASE_DIR="${TI_CGT6X_7_INSTALL_DIR}"
47export TOOLSC6X="${C6X_BASE_DIR}"
48export TOOLSC6XDOS="${C6X_BASE_DIR}"
49export TOOLSBIOSC6XDOS="${C6X_BASE_DIR}"
50export PDK_INSTALL_PATH = "${PDK_INSTALL_DIR}/packages"
51
52do_compile() {
53 cd src/make
54 for t in ${IBLTARGETS}
55 do
56 for e in ${IBLENDIAN}
57 do
58 make ${t} ENDIAN=${e} I2C_BUS_ADDR=0x51
59 done
60 done
61 cd -
62}
63
64do_install() {
65 install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/boot/ibl
66 cp -rP --preserve=mode,links,timestamps --no-preserve=ownership * ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/boot/ibl
67}
68
69FILES:${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages"
70
71INHIBIT_PACKAGE_STRIP = "1"
72INHIBIT_SYSROOT_STRIP = "1"
73INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
74
75INSANE_SKIP:${PN} = "arch file-rdeps"