summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/hyplnk-lld/hyplnk-lld-test_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/hyplnk-lld/hyplnk-lld-test_git.bb')
-rw-r--r--recipes-bsp/hyplnk-lld/hyplnk-lld-test_git.bb14
1 files changed, 3 insertions, 11 deletions
diff --git a/recipes-bsp/hyplnk-lld/hyplnk-lld-test_git.bb b/recipes-bsp/hyplnk-lld/hyplnk-lld-test_git.bb
index 8212c971..c33e2dfe 100644
--- a/recipes-bsp/hyplnk-lld/hyplnk-lld-test_git.bb
+++ b/recipes-bsp/hyplnk-lld/hyplnk-lld-test_git.bb
@@ -2,22 +2,14 @@ include hyplnk-lld.inc
2 2
3DEPENDS = "common-csl-ip hyplnk-lld" 3DEPENDS = "common-csl-ip hyplnk-lld"
4 4
5CHOICELIST = " yes \
6 no \
7"
8
9do_compile () { 5do_compile () {
10 make -f makefile_armv7 clean PDK_INSTALL_PATH="${STAGING_INCDIR}" \ 6 make -f makefile_armv7 clean PDK_INSTALL_PATH="${STAGING_INCDIR}" \
11 HYPLNK_SRC_DIR="${S}" 7 HYPLNK_SRC_DIR="${S}"
12 for device in ${DEVICELIST} 8 for device in ${DEVICELIST}
13 do 9 do
14 for choice in ${CHOICELIST} 10 make -f makefile_armv7 tests examples \
15 do 11 PDK_INSTALL_PATH="${STAGING_INCDIR}" \
16 make -f makefile_armv7 tests examples \ 12 DEVICE="$device" HYPLNK_SRC_DIR="${S}"
17 PDK_INSTALL_PATH="${STAGING_INCDIR}" \
18 DEVICE="$device" HYPLNK_SRC_DIR="${S}" \
19 USEDYNAMIC_LIB="$choice"
20 done
21 done 13 done
22} 14}
23 15