summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/hplib/hplib-mod_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/hplib/hplib-mod_git.bb')
-rw-r--r--recipes-bsp/hplib/hplib-mod_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-bsp/hplib/hplib-mod_git.bb b/recipes-bsp/hplib/hplib-mod_git.bb
new file mode 100644
index 00000000..acef1ce5
--- /dev/null
+++ b/recipes-bsp/hplib/hplib-mod_git.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "TI High Performance Library kernel module"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/runtime/hplib/module/COPYING.txt;md5=c1c4d3453cddc5b7f0ce84a277e66779"
4
5DEPENDS = "hplib"
6
7include hplib.inc
8
9# This package builds a kernel module, use kernel PR as base and append a local
10MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}"
11PR = "${MACHINE_KERNEL_PR}"
12
13S ="${WORKDIR}/git/ti/runtime/hplib/module"
14EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR} PDK_INSTALL_PATH=${STAGING_INCDIR}"
15
16inherit module
17
18do_install () {
19 oe_runmake install INSTALL_MOD_PATH="${D}"
20}