diff options
Diffstat (limited to 'recipes-bsp/cppi-lld/cppi-lld_git.bb')
-rwxr-xr-x | recipes-bsp/cppi-lld/cppi-lld_git.bb | 16 |
1 files changed, 15 insertions, 1 deletions
diff --git a/recipes-bsp/cppi-lld/cppi-lld_git.bb b/recipes-bsp/cppi-lld/cppi-lld_git.bb index bb2028b5..cd419f6a 100755 --- a/recipes-bsp/cppi-lld/cppi-lld_git.bb +++ b/recipes-bsp/cppi-lld/cppi-lld_git.bb | |||
@@ -5,15 +5,29 @@ DEPENDS = "common-csl-ip rm-lld qmss-lld" | |||
5 | 5 | ||
6 | include cppi-lld.inc | 6 | include cppi-lld.inc |
7 | 7 | ||
8 | SRC_URI += "file://init_cppi.sh" | ||
9 | |||
10 | inherit update-rc.d | ||
11 | |||
12 | INITSCRIPT_NAME = "init_cppi.sh" | ||
13 | INITSCRIPT_PARAMS = "defaults 10" | ||
14 | |||
8 | do_compile () { | 15 | do_compile () { |
9 | # Now build the lld in the updated directory | 16 | # Now build the lld in the updated directory |
10 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} | 17 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} |
11 | for device in ${DEVICELIST} | 18 | for device in ${DEVICELIST} |
12 | do | 19 | do |
13 | make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="${device}" | 20 | make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="${device}" |
14 | done | 21 | done |
15 | } | 22 | } |
16 | 23 | ||
17 | do_install () { | 24 | do_install () { |
18 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | 25 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} |
26 | # Set the generic device library symbolic link to default k2h | ||
27 | cd ${D}${libdir} | ||
28 | ln -sf libcppi_k2h.so.1.0.0 libcppi_device.so.1 | ||
29 | ln -sf libcppi_device.so.1 libcppi_device.so | ||
30 | # Copy init scripts | ||
31 | install -d ${D}${sysconfdir}/init.d/ | ||
32 | install -c -m 755 ${WORKDIR}/init_cppi.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
19 | } | 33 | } |